summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2018-11-02 20:16:56 +0100
committerPeter Simons <simons@cryp.to>2018-11-02 20:16:56 +0100
commitbf26876a2829232b45061976ed455c2048ebab1c (patch)
tree930cfa0b65bc26e5eb0f2a28f556c23c8bb97a9f /pkgs/shells
parent2f0de54ddbfdb03540128f8d2abcc47221d42b25 (diff)
downloadnixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar.gz
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar.bz2
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar.lz
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar.xz
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.tar.zst
nixlib-bf26876a2829232b45061976ed455c2048ebab1c.zip
zsh-git-prompt: don't hard-code any particular compiler version
Just use whatever is the current default.
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/zsh/zsh-git-prompt/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/shells/zsh/zsh-git-prompt/default.nix b/pkgs/shells/zsh/zsh-git-prompt/default.nix
index 7318da83d176..761ad071da95 100644
--- a/pkgs/shells/zsh/zsh-git-prompt/default.nix
+++ b/pkgs/shells/zsh/zsh-git-prompt/default.nix
@@ -29,10 +29,10 @@
 , python
 , git
 , lib
-, ghcVersion ? "ghc802"
+, haskellPackages
 }:
 
-haskell.packages.${ghcVersion}.callPackage
+haskellPackages.callPackage
   ({ mkDerivation, base, HUnit, parsec, process, QuickCheck, stdenv }:
    mkDerivation rec {
      pname = "zsh-git-prompt";