summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-06-10 09:27:04 +0000
committerRobin Gloster <mail@glob.in>2016-06-10 09:27:04 +0000
commit8031cba2ab3146977141fc504bea2a1e03b5c126 (patch)
tree0cd68c0007851dfed7d7f8247754b5c4b356704e /pkgs/shells
parent2a5e64b69c83592caf900cb0b7213235e96368de (diff)
parent656c48f141be5886c515a1a874a47472cbbac6bd (diff)
downloadnixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar.gz
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar.bz2
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar.lz
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar.xz
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.tar.zst
nixlib-8031cba2ab3146977141fc504bea2a1e03b5c126.zip
Merge remote-tracking branch 'upstream/master' into hardened-stdenv
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/es/default.nix2
-rw-r--r--pkgs/shells/fish/default.nix2
-rw-r--r--pkgs/shells/oh-my-zsh/default.nix2
-rw-r--r--pkgs/shells/oh/default.nix17
-rw-r--r--pkgs/shells/oh/deps.json10
-rw-r--r--pkgs/shells/xonsh/default.nix45
-rw-r--r--pkgs/shells/zsh-prezto/default.nix2
7 files changed, 60 insertions, 20 deletions
diff --git a/pkgs/shells/es/default.nix b/pkgs/shells/es/default.nix
index 3a4574fb8e16..ba9fe29c33e6 100644
--- a/pkgs/shells/es/default.nix
+++ b/pkgs/shells/es/default.nix
@@ -10,7 +10,7 @@ stdenv.mkDerivation {
   src = fetchgit {
     url = "git://github.com/wryun/es-shell";
     rev = "fdf29d5296ce3a0ef96d2b5952cff07878753975";
-    sha256 = "1hj0g8r59ry9l50h4gdal38nf8lvb3cgl6c9bx5aabkw5i778dfk";
+    sha256 = "12faa9b5ffwydgwyjp57zr19sqap2ma3crj6wd2rx1hv30dkll7p";
   };
 
   buildInputs = [ readline yacc libtool autoconf automake ];
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 6dd8d5290a4a..62ec6194fcd8 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -75,7 +75,7 @@ stdenv.mkDerivation rec {
     # make fish pick up completions from nix profile
     if status --is-interactive
       set -l profiles (echo $NIX_PROFILES | ${coreutils}/bin/tr ' ' '\n')
-      set fish_complete_path $profiles"/share/fish/vendor_completions.d" $fish_complete_path
+      set fish_complete_path \$profiles"/share/fish/vendor_completions.d" \$fish_complete_path
     end
     EOF
   '';
diff --git a/pkgs/shells/oh-my-zsh/default.nix b/pkgs/shells/oh-my-zsh/default.nix
index 78b112210acf..473b364981b7 100644
--- a/pkgs/shells/oh-my-zsh/default.nix
+++ b/pkgs/shells/oh-my-zsh/default.nix
@@ -12,7 +12,7 @@ stdenv.mkDerivation rec {
   src = fetchgit {
     url = "https://github.com/robbyrussell/oh-my-zsh";
     rev = "1b1315a777328095cd8b5f364fd4345eeae7c4bf";
-    sha256 = "0q3w96a9rjxmqknycxjqjs5mi0q2mark8yrfim7snxrf9ajv0ypk";
+    sha256 = "1bdh6k46kwggihw6iblm1q60x4hjxpbkhaqap0nfpapqvlba4nv6";
   };
 
   phases = "installPhase";
diff --git a/pkgs/shells/oh/default.nix b/pkgs/shells/oh/default.nix
new file mode 100644
index 000000000000..c6d3ad06df46
--- /dev/null
+++ b/pkgs/shells/oh/default.nix
@@ -0,0 +1,17 @@
+{ stdenv, lib, buildGoPackage, fetchgit, fetchhg, fetchbzr, fetchsvn }:
+
+buildGoPackage rec {
+  name = "oh-${version}";
+  version = "20160522-${stdenv.lib.strings.substring 0 7 rev}";
+  rev = "0daaf4081475fb9d6b3801c85019bdd57b2ee9b4";
+
+  goPackagePath = "github.com/michaelmacinnis/oh";
+
+  src = fetchgit {
+    inherit rev;
+    url = "https://github.com/michaelmacinnis/oh";
+    sha256 = "0ajidzs0aisbw74nri9ks6sx6644nmwkisc9mvxm3f89zmnlsgwr";
+  };
+
+  goDeps = ./deps.json;
+}
diff --git a/pkgs/shells/oh/deps.json b/pkgs/shells/oh/deps.json
new file mode 100644
index 000000000000..a0e67ed42dcc
--- /dev/null
+++ b/pkgs/shells/oh/deps.json
@@ -0,0 +1,10 @@
+[
+  {
+    "include": "../../libs.json",
+    "packages": [
+      "github.com/michaelmacinnis/adapted",
+      "github.com/peterh/liner",
+      "golang.org/x/sys"
+    ]
+  }
+]
diff --git a/pkgs/shells/xonsh/default.nix b/pkgs/shells/xonsh/default.nix
index 5af78c27266f..395132bc2d82 100644
--- a/pkgs/shells/xonsh/default.nix
+++ b/pkgs/shells/xonsh/default.nix
@@ -1,31 +1,44 @@
-{stdenv, fetchurl, python3Packages}:
+{ stdenv, fetchFromGitHub, python3Packages, glibcLocales, coreutils }:
 
 python3Packages.buildPythonApplication rec {
   name = "xonsh-${version}";
-  version = "0.2.7";
+  version = "0.3.2";
 
-  # The logo xonsh prints during build contains unicode characters, and this
-  # fails because locales have not been set up in the build environment.
-  # We can fix this on Linux by setting:
-  #    export LOCALE_ARCHIVE=${pkgs.glibcLocales}/lib/locale/locale-archive
-  # but this would not be a cross platform solution, so it's simpler to just
-  # patch the setup.py script to not print the logo during build.
-  prePatch = ''
-    substituteInPlace setup.py --replace "print(logo)" ""
+  src = fetchFromGitHub {
+    owner = "scopatz";
+    repo = "xonsh";
+    rev = version;
+    sha256= "0cqfrpvkgzk0q3dykavqxwfqrx61y8rbzixmwcv8pfa9r2sya24q";
+  };
+
+  ## The logo xonsh prints during build contains unicode characters, and this
+  ## fails because locales have not been set up in the build environment.
+  ## We can fix this on Linux by setting:
+  ##    export LOCALE_ARCHIVE=${pkgs.glibcLocales}/lib/locale/locale-archive
+  ## but this would not be a cross platform solution, so it's simpler to just
+  ## patch the setup.py script to not print the logo during build.
+  #prePatch = ''
+  #  substituteInPlace setup.py --replace "print(logo)" ""
+  #'';
+  patchPhase = ''
+    rm xonsh/winutils.py
+    sed -i -e "s|/bin/ls|${coreutils}/bin/ls|" tests/test_execer.py
+    rm tests/test_main.py
+    rm tests/test_man.py
   '';
 
-  propagatedBuildInputs = [ python3Packages.ply ];
+  checkPhase = ''
+    HOME=$TMPDIR nosetests -x
+  '';
 
-  src = fetchurl {
-    url = "mirror://pypi/x/xonsh/${name}.tar.gz";
-    sha256= "10pglgmzj6l0l8mb3r2rxnbigqigcqn9njcgdcrg7s1b409cq4md";
-  };
+  buildInputs = with python3Packages; [ glibcLocales nose pygments ];
+  propagatedBuildInputs = with python3Packages; [ ply prompt_toolkit ];
 
   meta = with stdenv.lib; {
     description = "A Python-ish, BASHwards-compatible shell";
     homepage = "http://xonsh.org";
     license = licenses.bsd3;
-    maintainers = [ maintainers.spwhitt ];
+    maintainers = with maintainers; [ spwhitt garbas ];
     platforms = platforms.all;
   };
 }
diff --git a/pkgs/shells/zsh-prezto/default.nix b/pkgs/shells/zsh-prezto/default.nix
index 96b8cdd62500..0a2e784b17d6 100644
--- a/pkgs/shells/zsh-prezto/default.nix
+++ b/pkgs/shells/zsh-prezto/default.nix
@@ -14,7 +14,7 @@ in stdenv.mkDerivation rec {
   src = fetchgit {
     url = "https://github.com/sorin-ionescu/prezto";
     inherit rev;
-    sha256 = "1q137r2vv16cq962n0f2hyn8m04d3phvh72gz737zv99jcrqg821";
+    sha256 = "17mql9mb7zbf8q1nvnci60yrmz5bl9q964i8dv4shz8b42861cdg";
     fetchSubmodules = true;
   };
   patches = [