summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2018-10-08 19:38:07 +0000
committerGitHub <noreply@github.com>2018-10-08 19:38:07 +0000
commit6bfc436433cec006339807e902938a02cd33f0e2 (patch)
tree700074c9a4ab783a2cb0dc98977b9a382a089f52 /pkgs/shells
parent15aa8caf57c31b8d8c817dce13209f7d4378d1da (diff)
parentceb0d1a5658c1c27b48ef52504809f78cef70e79 (diff)
downloadnixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar.gz
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar.bz2
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar.lz
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar.xz
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.tar.zst
nixlib-6bfc436433cec006339807e902938a02cd33f0e2.zip
Merge pull request #46743 from haslersn/any-nix-shell-1.1.0
any-nix-shell: init at 1.1.0
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/any-nix-shell/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/shells/any-nix-shell/default.nix b/pkgs/shells/any-nix-shell/default.nix
new file mode 100644
index 000000000000..21f40858ea28
--- /dev/null
+++ b/pkgs/shells/any-nix-shell/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchFromGitHub, makeWrapper }:
+
+stdenv.mkDerivation rec {
+  name = "any-nix-shell-${version}";
+  version = "1.1.0";
+
+  src = fetchFromGitHub {
+    owner = "haslersn";
+    repo = "any-nix-shell";
+    rev = "v${version}";
+    sha256 = "02cv86csk1m8nlh2idvh7bjw43lpssmdawya2jhr4bam2606yzdv";
+  };
+
+  nativeBuildInputs = [ makeWrapper ];
+  installPhase = ''
+    mkdir -p $out/bin
+    cp -r bin $out
+    wrapProgram $out/bin/any-nix-shell --prefix PATH ":" $out/bin
+  '';
+
+  meta = with stdenv.lib; {
+    description = "fish and zsh support for nix-shell";
+    license = licenses.mit;
+    homepage = https://github.com/haslersn/any-nix-shell;
+    maintainers = with maintainers; [ haslersn ];
+  };
+}
\ No newline at end of file