summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2011-09-24 07:58:19 +0000
committerPeter Simons <simons@cryp.to>2011-09-24 07:58:19 +0000
commit3e09798bf4693cdda805a029f88423721d82874f (patch)
treeefcc2f60a03f7aaffb8e3d50d17af7e4281bd8e0 /pkgs/shells
parent0a5f021abd22da25b6c835b30d137563ad8f0eaa (diff)
downloadnixlib-3e09798bf4693cdda805a029f88423721d82874f.tar
nixlib-3e09798bf4693cdda805a029f88423721d82874f.tar.gz
nixlib-3e09798bf4693cdda805a029f88423721d82874f.tar.bz2
nixlib-3e09798bf4693cdda805a029f88423721d82874f.tar.lz
nixlib-3e09798bf4693cdda805a029f88423721d82874f.tar.xz
nixlib-3e09798bf4693cdda805a029f88423721d82874f.tar.zst
nixlib-3e09798bf4693cdda805a029f88423721d82874f.zip
pkgs/shells/bash/default.nix: revert my earlier revision 29244
Including the bash-completion package in bash itself sounded like a good idea
at the time, but it wasn't. After having actually integrated completion support
into NixOS, it has become obvious that this property isn't required at all.
Keeping bash-completion separate from bash works just fine. Anyone who wants
completion support can just install that package.

svn path=/nixpkgs/trunk/; revision=29467
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/bash/default.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/pkgs/shells/bash/default.nix b/pkgs/shells/bash/default.nix
index e289395bc995..3a0515199b6e 100644
--- a/pkgs/shells/bash/default.nix
+++ b/pkgs/shells/bash/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, readline ? null, interactive ? false, texinfo ? null, bison, bashCompletion ? null}:
+{ stdenv, fetchurl, readline ? null, interactive ? false, texinfo ? null, bison }:
 
 assert interactive -> readline != null;
 
@@ -52,10 +52,7 @@ stdenv.mkDerivation rec {
     # Add an `sh' -> `bash' symlink.
     ln -s bash "$out/bin/sh"
 
-  '' + (if interactive && bashCompletion != null then ''
-    ensureDir "$out/etc"
-    echo >"$out/etc/bash_completion" '. "${bashCompletion}/etc/bash_completion"'
-  '' else ''
+  '' + (if interactive then "" else ''
     # Install the completion examples.
     ensureDir "$out/etc"
     cp -v "examples/complete/bash_completion" "$out/etc"