summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-06-01 21:15:43 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-06-04 14:54:49 +0200
commitef5647d7570181ebf936ca3056145e809836428e (patch)
treefd5eb0fcbee6e8b8913d339cc1bd5c306a17e09a /pkgs/servers
parentf4b5cd8dde3cfc87bc5d344093fb91bc229eadcf (diff)
downloadnixlib-ef5647d7570181ebf936ca3056145e809836428e.tar
nixlib-ef5647d7570181ebf936ca3056145e809836428e.tar.gz
nixlib-ef5647d7570181ebf936ca3056145e809836428e.tar.bz2
nixlib-ef5647d7570181ebf936ca3056145e809836428e.tar.lz
nixlib-ef5647d7570181ebf936ca3056145e809836428e.tar.xz
nixlib-ef5647d7570181ebf936ca3056145e809836428e.tar.zst
nixlib-ef5647d7570181ebf936ca3056145e809836428e.zip
Revert "postgresql: 9.3.6 -> 9.3.7"
This reverts commit 5486c08dc27c5cdc7b251adf6d50d306501ba3b1.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/9.3.x.nix47
-rw-r--r--pkgs/servers/sql/postgresql/generic.nix3
2 files changed, 41 insertions, 9 deletions
diff --git a/pkgs/servers/sql/postgresql/9.3.x.nix b/pkgs/servers/sql/postgresql/9.3.x.nix
index 9671c316832d..4406aecaa897 100644
--- a/pkgs/servers/sql/postgresql/9.3.x.nix
+++ b/pkgs/servers/sql/postgresql/9.3.x.nix
@@ -1,11 +1,44 @@
-{ callPackage, fetchurl, ... } @ args:
+{ stdenv, fetchurl, zlib, readline, libossp_uuid, openssl}:
 
-callPackage ./generic.nix (args // rec {
-  psqlSchema = "9.3";
-  version = "${psqlSchema}.7";
+with stdenv.lib;
+
+let version = "9.3.6"; in
+
+stdenv.mkDerivation rec {
+  name = "postgresql-${version}";
 
   src = fetchurl {
-    url = "mirror://postgresql/source/v${version}/postgresql-${version}.tar.bz2";
-    sha256 = "09iqr9sldiq7jz1rdnywp2wv36lxy5m8kch3vpchd1s4fz75c7aw";
+    url = "mirror://postgresql/source/v${version}/${name}.tar.bz2";
+    sha256 = "056ass7nnfyv7blv02anv795kgpz77gipdpxggd835cdwrhwns13";
+  };
+
+  buildInputs = [ zlib readline openssl ]
+                ++ optionals (!stdenv.isDarwin) [ libossp_uuid ];
+
+  enableParallelBuilding = true;
+
+  makeFlags = [ "world" ];
+
+  configureFlags = [ "--with-openssl" ]
+                   ++ optional (!stdenv.isDarwin) "--with-ossp-uuid";
+
+  patches = [ ./disable-resolve_symlinks.patch ./less-is-more.patch ];
+
+  installTargets = [ "install-world" ];
+
+  LC_ALL = "C";
+
+  passthru = {
+    inherit readline;
+    psqlSchema = "9.3";
+  };
+
+  meta = with stdenv.lib; {
+    homepage = http://www.postgresql.org/;
+    description = "A powerful, open source object-relational database system";
+    license = licenses.postgresql;
+    maintainers = with maintaiers; [ ocharles ];
+    platforms = platforms.unix;
+    hydraPlatforms = platforms.linux;
   };
-})
+}
diff --git a/pkgs/servers/sql/postgresql/generic.nix b/pkgs/servers/sql/postgresql/generic.nix
index 88e2b77cf83c..46d2030224d8 100644
--- a/pkgs/servers/sql/postgresql/generic.nix
+++ b/pkgs/servers/sql/postgresql/generic.nix
@@ -52,6 +52,7 @@ stdenv.mkDerivation rec {
     (mkEnable true                      "integer-datetimes" null)
     (mkEnable true                      "nls"               null)
     (mkWith   true                      "pgport"            "5432")
+    (mkEnable true                      "shared"            null)
     (mkEnable true                      "rpath"             null)
     (mkEnable true                      "spinlocks"         null)
     (mkEnable false                     "debug"             null)
@@ -82,8 +83,6 @@ stdenv.mkDerivation rec {
     (mkWith   (optZlib != null)         "zlib"              null)
   ] ++ optionals (versionAtLeast version "9.1.0") [
     (mkWith   false                     "selinux"           null)
-  ] ++ optionals (versionOlder version "9.3.0") [
-    (mkEnable true                      "shared"            null)
   ];
 
   enableParallelBuilding = true;