summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorTristan Helmich <tristan.helmich@gmail.com>2017-01-16 12:52:29 +0100
committerRobin Gloster <mail@glob.in>2017-01-16 12:54:43 +0100
commitef0f4e70927bfcf00ed53c2015f84a3c862c320b (patch)
tree6118a1d121edca8e83f134a36c43d5ae1a4ea0dd /pkgs/servers
parent28093e42ec047dcfa440bfaa256690c92085b369 (diff)
downloadnixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar.gz
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar.bz2
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar.lz
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar.xz
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.tar.zst
nixlib-ef0f4e70927bfcf00ed53c2015f84a3c862c320b.zip
couchpotato: init at 3.0.1
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/couchpotato/default.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/pkgs/servers/couchpotato/default.nix b/pkgs/servers/couchpotato/default.nix
new file mode 100644
index 000000000000..a996cec0d5b5
--- /dev/null
+++ b/pkgs/servers/couchpotato/default.nix
@@ -0,0 +1,43 @@
+{ fetchurl, pythonPackages, lib }:
+
+with pythonPackages;
+
+buildPythonApplication rec {
+  name = "couchpotato-${version}";
+  version = "3.0.1";
+  disabled = isPy3k;
+
+  src = fetchurl {
+    url = "https://github.com/CouchPotato/CouchPotatoServer/archive/build/${version}.tar.gz";
+    sha256 = "1xwjis3ijh1rff32mpdsphmsclf0lkpd3phpgxkccrigq1m9r3zh";
+  };
+
+  format = "other";
+
+  postPatch = ''
+    substituteInPlace CouchPotato.py --replace "dirname(os.path.abspath(__file__))" "os.path.join(dirname(os.path.abspath(__file__)), '../${python.sitePackages}')"
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin/
+    mkdir -p $out/${python.sitePackages}/
+
+    cp -r libs/* $out/${python.sitePackages}/
+    cp -r couchpotato $out/${python.sitePackages}/
+
+    cp CouchPotato.py $out/bin/couchpotato
+    chmod +x $out/bin/*
+  '';
+
+  fixupPhase = ''
+    wrapProgram "$out/bin/couchpotato" --set PYTHONPATH "$PYTHONPATH:$out/${python.sitePackages}" \
+                                       --set PATH ${python}/bin
+  '';
+
+  meta = {
+    description = "Automatic movie downloading via NZBs and torrents";
+    license     = lib.licenses.gpl3;
+    homepage    = https://couchpota.to/;
+    maintainers = with lib.maintainers; [ fadenb ];
+  };
+}