summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2016-03-11 23:03:14 +0000
committerzimbatm <zimbatm@zimbatm.com>2016-03-12 15:31:23 +0000
commiteac89788da77c95529b4cc29bc03a9b4e1f8af86 (patch)
treea27950005b416b00558b5c24c58cc3f969214ba8 /pkgs/servers
parent2f398c365f337d48c374dacecec698d982e6592e (diff)
downloadnixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar.gz
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar.bz2
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar.lz
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar.xz
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.tar.zst
nixlib-eac89788da77c95529b4cc29bc03a9b4e1f8af86.zip
apacheHttpd: add support for HTTP/2
In NixOS you can enable HTTP/2 like this:

    services.httpd.extraModules = [ "http2" ];
    services.httpd.extraConfig = ''
      Protocols h2 http/1.1
    '';
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
index ddb1ec443a06..a2e039bd399f 100644
--- a/pkgs/servers/http/apache-httpd/2.4.nix
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -1,6 +1,7 @@
 { stdenv, fetchurl, perl, zlib, apr, aprutil, pcre, libiconv
 , proxySupport ? true
 , sslSupport ? true, openssl
+, http2Support ? true, libnghttp2
 , ldapSupport ? true, openldap
 , libxml2Support ? true, libxml2
 , luaSupport ? false, lua5
@@ -12,6 +13,7 @@ in
 
 assert sslSupport -> aprutil.sslSupport && openssl != null;
 assert ldapSupport -> aprutil.ldapSupport && openldap != null;
+assert http2Support -> libnghttp2 != null;
 
 stdenv.mkDerivation rec {
   version = "2.4.18";
@@ -25,6 +27,7 @@ stdenv.mkDerivation rec {
   buildInputs = [perl] ++
     optional ldapSupport openldap ++    # there is no --with-ldap flag
     optional libxml2Support libxml2 ++
+    optional http2Support libnghttp2 ++
     optional stdenv.isDarwin libiconv;
 
   # Required for ‘pthread_cancel’.
@@ -44,6 +47,7 @@ stdenv.mkDerivation rec {
     --enable-cgi
     ${optionalString proxySupport "--enable-proxy"}
     ${optionalString sslSupport "--enable-ssl --with-ssl=${openssl}"}
+    ${optionalString http2Support "--enable-http2 --with-nghttp2=${libnghttp2}"}
     ${optionalString luaSupport "--enable-lua --with-lua=${lua5}"}
     ${optionalString libxml2Support "--with-libxml2=${libxml2}/include/libxml2"}
   '';