summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-05-05 15:48:14 -0500
committerGitHub <noreply@github.com>2018-05-05 15:48:14 -0500
commitea1d75e442af712c3eb4c167741ad26c54406514 (patch)
tree20440ae8b1ca5c1467b7230400dca31cda7c9216 /pkgs/servers
parenta67cca803fe27e4c5ddc193ce563a030a41ca9e0 (diff)
parent554e296c9fb46de531affb1aea54e5d29830485b (diff)
downloadnixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar.gz
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar.bz2
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar.lz
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar.xz
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.tar.zst
nixlib-ea1d75e442af712c3eb4c167741ad26c54406514.zip
Merge pull request #39925 from Assassinkin/master
Zabbix-agent 3.4
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/zabbix/3.4.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/pkgs/servers/monitoring/zabbix/3.4.nix b/pkgs/servers/monitoring/zabbix/3.4.nix
new file mode 100644
index 000000000000..332e139f4283
--- /dev/null
+++ b/pkgs/servers/monitoring/zabbix/3.4.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchurl, pkgconfig, postgresql, curl, openssl, zlib, pcre, libevent, libiconv }:
+
+
+let
+
+  version = "3.4.8";
+  branch = "3.4";
+
+  src = fetchurl {
+    url = "https://netix.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${version}/zabbix-${version}.tar.gz";
+    sha256 = "cec14993d1ec2c9d8c51f6608c9408620f27174db92edc2347bafa7b841ccc07";
+  };
+
+in
+
+{
+  agent = stdenv.mkDerivation {
+    name = "zabbix-agent-${version}";
+
+    inherit src;
+
+     configureFlags = [
+      "--enable-agent"
+      "--with-libpcre=${pcre.dev}"
+      "--with-iconv=${libiconv}"
+    ];
+    buildInputs = [ pcre libiconv ];
+
+    meta = with stdenv.lib; {
+      inherit branch;
+      description = "An enterprise-class open source distributed monitoring solution (client-side agent)";
+      homepage = http://www.zabbix.com/;
+      license = licenses.gpl2;
+      maintainers = [ maintainers.eelco ];
+      platforms = platforms.linux;
+    };
+  };
+
+}
+