summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-13 21:51:53 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-14 14:27:07 +0200
commite25da7e5c8bceaccb15d25dd0fcce5a0104f376d (patch)
tree9a17a42d712b75a24df0aad9ac25ffe247c01d35 /pkgs/servers
parent8c25f3ecaa204fb31a523b55c5be3d10a0c79f8e (diff)
downloadnixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar.gz
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar.bz2
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar.lz
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar.xz
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.tar.zst
nixlib-e25da7e5c8bceaccb15d25dd0fcce5a0104f376d.zip
xorg: split outputs of various libs
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/x11/xorg/overrides.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/servers/x11/xorg/overrides.nix b/pkgs/servers/x11/xorg/overrides.nix
index b4c15f016370..3b72494e8968 100644
--- a/pkgs/servers/x11/xorg/overrides.nix
+++ b/pkgs/servers/x11/xorg/overrides.nix
@@ -106,6 +106,7 @@ in
   };
 
   libXfont = attrs: attrs // {
+    outputs = [ "dev" "out" ];
     propagatedBuildInputs = [ args.freetype ]; # propagate link reqs. like bzip2
     # prevents "misaligned_stack_error_entering_dyld_stub_binder"
     configureFlags = lib.optionals isDarwin [
@@ -150,6 +151,7 @@ in
   };
 
   libXaw = attrs: attrs // {
+    outputs = [ "dev" "out" "doc" ]; # just dev-doc
     propagatedBuildInputs = [ xorg.libXmu ];
   };
 
@@ -210,10 +212,19 @@ in
     preConfigure = setMalloc0ReturnsNullCrossCompiling;
   };
 
+  libXres = attrs: attrs // {
+    outputs = [ "dev" "out" "doc" ]; # just dev-doc
+  };
+
+  libXv = attrs: attrs // {
+    outputs = [ "dev" "out" "doc" ]; # just dev-doc
+  };
+
   libXvMC = attrs: attrs
     // { buildInputs = attrs.buildInputs ++ [xorg.renderproto]; };
 
   libXpm = attrs: attrs // {
+    outputs = [ "dev" "out" "bin" ]; # tiny man in $bin
     patchPhase = "sed -i '/USE_GETTEXT_TRUE/d' sxpm/Makefile.in cxpm/Makefile.in";
   };
 
@@ -224,6 +235,10 @@ in
     outputs = [ "dev" "out" ]; # mainly to avoid propagation
   };
 
+  libxshmfence = attrs: attrs // {
+    outputs = [ "dev" "out" ]; # mainly to avoid propagation
+  };
+
   setxkbmap = attrs: attrs // {
     postInstall =
       ''
@@ -248,10 +263,22 @@ in
     meta.maintainers = [ stdenv.lib.maintainers.lovek323 ];
   };
 
+  xcbutilimage = attrs: attrs // {
+    outputs = [ "dev" "out" ]; # mainly to get rid of propagating others
+  };
+
   xcbutilkeysyms = attrs: attrs // {
     outputs = [ "dev" "out" ]; # mainly to get rid of propagating others
   };
 
+  xcbutilrenderutil = attrs: attrs // {
+    outputs = [ "dev" "out" ]; # mainly to get rid of propagating others
+  };
+
+  xcbutilwm = attrs: attrs // {
+    outputs = [ "dev" "out" ]; # mainly to get rid of propagating others
+  };
+
   xf86inputevdev = attrs: attrs // {
     preBuild = "sed -e '/motion_history_proc/d; /history_size/d;' -i src/*.c";
     installFlags = "sdkdir=\${out}/include/xorg";
@@ -361,6 +388,7 @@ in
     in
       if (!isDarwin)
       then {
+        outputs = [ "dev" "out" ];
         buildInputs = [ makeWrapper ] ++ commonBuildInputs;
         propagatedBuildInputs = [ libpciaccess ] ++ commonPropagatedBuildInputs ++ lib.optionals stdenv.isLinux [
           args.udev