summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2015-10-01 14:23:22 +0200
committerThomas Strobel <ts468@cam.ac.uk>2015-10-01 15:30:34 +0200
commite0d5b14ce412f6ff629d4fb5104d34a0b00804b7 (patch)
tree200bc90f5ca0150e436ef5dc9a12b3a450bf55a1 /pkgs/servers
parent375ab720b3e7a1939fe38e2cbe134289fcab0cd1 (diff)
downloadnixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar.gz
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar.bz2
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar.lz
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar.xz
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.tar.zst
nixlib-e0d5b14ce412f6ff629d4fb5104d34a0b00804b7.zip
neard: enable support for Secure Elements
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/neard/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/servers/neard/default.nix b/pkgs/servers/neard/default.nix
index a76f10a262db..995ffc41c60e 100644
--- a/pkgs/servers/neard/default.nix
+++ b/pkgs/servers/neard/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ autoreconfHook pkgconfig systemd glib dbus libnl pythonPackages.python pythonPackages.wrapPython ];
   pythonPath = [ pythonPackages.pygobject pythonPackages.dbus pythonPackages.pygtk ];
 
-  configureFlags = [ "--disable-debug" "--enable-tools" "--with-systemdsystemunitdir=$out/lib/systemd/system" ];
+  configureFlags = [ "--disable-debug" "--enable-tools" "--enable-ese" "--with-systemdsystemunitdir=$out/lib/systemd/system" ];
 
   postInstall = ''
     install -m 0755 tools/snep-send $out/bin/
@@ -19,6 +19,7 @@ stdenv.mkDerivation rec {
     install -D -m644 src/neard.service $out/lib/systemd/system/neard.service
     install -D -m644 src/main.conf $out/etc/neard/main.conf
 
+    # INFO: the config option "--enable-test" would copy the apps to $out/lib/neard/test/ instead
     install -d $out/lib/neard
     install -m 0755 test/* $out/lib/neard/
     wrapPythonProgramsIn $out/lib/neard "$out $pythonPath"