summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-02-23 12:38:11 +0000
committerGitHub <noreply@github.com>2018-02-23 12:38:11 +0000
commitdf4963daca38d9b0d5d0b0269c99c5485ed9150a (patch)
tree77f4a61922c711b5e48f9d61fd7c29a5b1cc75a7 /pkgs/servers
parent4ec94f679c55a3fed5a618eb3a2092404a0fb885 (diff)
parentc6cd69341afe66ee15d4eb0ab3b6e203ac8b99f2 (diff)
downloadnixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar.gz
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar.bz2
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar.lz
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar.xz
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.tar.zst
nixlib-df4963daca38d9b0d5d0b0269c99c5485ed9150a.zip
Merge pull request #35343 from gnidorah/softether
softether module: fix dataDir option
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/softether/4.18.nix6
-rw-r--r--pkgs/servers/softether/4.20.nix6
-rw-r--r--pkgs/servers/softether/4.25.nix6
3 files changed, 9 insertions, 9 deletions
diff --git a/pkgs/servers/softether/4.18.nix b/pkgs/servers/softether/4.18.nix
index 69c6cbe2c864..5b0d15136f89 100644
--- a/pkgs/servers/softether/4.18.nix
+++ b/pkgs/servers/softether/4.18.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl
-, openssl, readline, ncurses, zlib }:
+, openssl, readline, ncurses, zlib
+, dataDir ? "/var/lib/softether" }:
 
 let
   os = if stdenv.isLinux then "1"
@@ -17,7 +18,6 @@ stdenv.mkDerivation rec {
   version = "4.18";
   build = "9570";
   compiledDate = "2015.07.26";
-  dataDir = "/var/lib/softether";
 
   src = fetchurl {
     url = "http://www.softether-download.com/files/softether/v${version}-${build}-rtm-${compiledDate}-tree/Source_Code/softether-src-v${version}-${build}-rtm.tar.gz";
@@ -48,6 +48,6 @@ stdenv.mkDerivation rec {
     homepage = https://www.softether.org/;
     license = licenses.gpl2;
     maintainers = [ maintainers.rick68 ];
-    platforms = platforms.linux;
+    platforms = filter (p: p != "aarch64-linux") platforms.linux;
   };
 }
diff --git a/pkgs/servers/softether/4.20.nix b/pkgs/servers/softether/4.20.nix
index c6ef5a3a4df2..91dd0d0411f8 100644
--- a/pkgs/servers/softether/4.20.nix
+++ b/pkgs/servers/softether/4.20.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl
-, openssl, readline, ncurses, zlib }:
+, openssl, readline, ncurses, zlib
+, dataDir ? "/var/lib/softether" }:
 
 let
   os = if stdenv.isLinux then "1"
@@ -17,7 +18,6 @@ stdenv.mkDerivation rec {
   version = "4.20";
   build = "9608";
   compiledDate = "2016.04.17";
-  dataDir = "/var/lib/softether";
 
   src = fetchurl {
     url = "http://www.softether-download.com/files/softether/v${version}-${build}-rtm-${compiledDate}-tree/Source_Code/softether-src-v${version}-${build}-rtm.tar.gz";
@@ -48,6 +48,6 @@ stdenv.mkDerivation rec {
     homepage = https://www.softether.org/;
     license = licenses.gpl2;
     maintainers = [ maintainers.rick68 ];
-    platforms = platforms.linux;
+    platforms = filter (p: p != "aarch64-linux") platforms.linux;
   };
 }
diff --git a/pkgs/servers/softether/4.25.nix b/pkgs/servers/softether/4.25.nix
index b1e9c5c1a455..04053174f4e4 100644
--- a/pkgs/servers/softether/4.25.nix
+++ b/pkgs/servers/softether/4.25.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl
-, openssl, readline, ncurses, zlib }:
+, openssl, readline, ncurses, zlib
+, dataDir ? "/var/lib/softether" }:
 
 let
   os = if stdenv.isLinux then "1"
@@ -17,7 +18,6 @@ stdenv.mkDerivation rec {
   version = "4.25";
   build = "9656";
   compiledDate = "2018.01.15";
-  dataDir = "/var/lib/softether";
 
   src = fetchurl {
     url = "http://www.softether-download.com/files/softether/v${version}-${build}-rtm-${compiledDate}-tree/Source_Code/softether-src-v${version}-${build}-rtm.tar.gz";
@@ -48,6 +48,6 @@ stdenv.mkDerivation rec {
     homepage = https://www.softether.org/;
     license = licenses.gpl2;
     maintainers = [ maintainers.rick68 ];
-    platforms = platforms.linux;
+    platforms = filter (p: p != "aarch64-linux") platforms.linux;
   };
 }