summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMatt McHenry <github@matt.mchenryfamily.org>2017-09-04 12:50:50 -0400
committerJörg Thalheim <joerg@thalheim.io>2017-09-04 18:37:01 +0100
commitdbf97a5afec913bf27c69650c5bb2cd5ccef5947 (patch)
tree9340c25882380311cc8e1e79218abd273999c212 /pkgs/servers
parentfc391e7ecd636e23640d6e296066ac19d5655108 (diff)
downloadnixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar.gz
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar.bz2
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar.lz
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar.xz
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.tar.zst
nixlib-dbf97a5afec913bf27c69650c5bb2cd5ccef5947.zip
pfixtools: patch to work with gcc 6
Progress on: #28643
fixes #28984
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/postfix/pfixtools.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/servers/mail/postfix/pfixtools.nix b/pkgs/servers/mail/postfix/pfixtools.nix
index 6a0d7fb588fd..a4186559e89f 100644
--- a/pkgs/servers/mail/postfix/pfixtools.nix
+++ b/pkgs/servers/mail/postfix/pfixtools.nix
@@ -40,7 +40,7 @@ stdenv.mkDerivation {
                       --replace /bin/bash ${bash}/bin/bash;
   '';
 
-  NIX_CFLAGS_COMPILE = "-Wno-error=unused-result";
+  NIX_CFLAGS_COMPILE = "-Wno-error=unused-result -Wno-error=nonnull-compare";
 
   makeFlags = "DESTDIR=$(out) prefix=";
 
@@ -49,5 +49,6 @@ stdenv.mkDerivation {
     license = with lib.licenses; [ bsd3 ];
     homepage = https://github.com/Fruneau/pfixtools;
     platforms = stdenv.lib.platforms.linux;
+    maintainers = with lib.maintainers; [ jerith666 ];
   };
 }