summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorSimon Vandel Sillesen <simon.vandel@gmail.com>2015-10-21 09:01:42 +0200
committerSimon Vandel Sillesen <simon.vandel@gmail.com>2015-10-21 09:01:42 +0200
commitd495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd (patch)
tree327533f9ece4916bf41d3f90ded9769b27b021c1 /pkgs/servers
parentf77bf46c1e705934a00c52d90cc62a76fbb1f6b5 (diff)
downloadnixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar.gz
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar.bz2
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar.lz
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar.xz
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.tar.zst
nixlib-d495ac2957ea63dfc4dd8d5e14753ee1d9ffbebd.zip
tvheadend: 4.0.4 -> 4.0.6
Added a comment about network download, and cleaned it up a little
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/tvheadend/default.nix18
1 files changed, 12 insertions, 6 deletions
diff --git a/pkgs/servers/tvheadend/default.nix b/pkgs/servers/tvheadend/default.nix
index c7b4e5153176..79bade94569f 100644
--- a/pkgs/servers/tvheadend/default.nix
+++ b/pkgs/servers/tvheadend/default.nix
@@ -1,19 +1,25 @@
 {avahi, dbus, fetchurl, git, gzip, libav, libiconv, openssl, pkgconfig, python
 , stdenv, which, zlib}:
 
-let version = "4.0.4";
-    pkgName = "tvheadend"; in
+with stdenv.lib;
+
+let version = "4.0.6";
+    pkgName = "tvheadend";
+
+in
 
 stdenv.mkDerivation rec {
   name = "${pkgName}-${version}";
 
   src = fetchurl {
     url = "https://github.com/tvheadend/tvheadend/archive/v${version}.tar.gz";
-    sha256 = "acc5c852bccb32d6a281f523e78a1cceb4d41987fe015aba3f66e1898b02c168";
+    sha256 = "05jidg7jma3mban40iy1bg3sirw6crscxkd8b70if4kjlf86i31l";
   };
 
   enableParallelBuilding = true;
 
+  # disable dvbscan, as having it enabled causes a network download which
+  # cannot happen during build.
   configureFlags = [ "--disable-dvbscan" ];
 
   buildInputs = [ avahi dbus git gzip libav libiconv openssl pkgconfig python
@@ -28,8 +34,8 @@ stdenv.mkDerivation rec {
         supporting DVB-S, DVB-S2, DVB-C, DVB-T, ATSC, IPTV, SAT>IP and HDHomeRun as input sources.
 	Tvheadend offers the HTTP (VLC, MPlayer), HTSP (Kodi, Movian) and SAT>IP streaming.'';
     homepage = "https://tvheadend.org";
-    license = stdenv.lib.licenses.gpl3;
-    platforms = stdenv.lib.platforms.unix;
-    maintainers = [ stdenv.lib.maintainers.simonvandel ];
+    license = licenses.gpl3;
+    platforms = platforms.unix;
+    maintainers = [ maintainers.simonvandel ];
   };
 }