summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRobert Schütz <rschuetz17@gmail.com>2018-04-17 11:57:32 +0200
committerGitHub <noreply@github.com>2018-04-17 11:57:32 +0200
commitc6a8b90d153643ff5eaaa378b8db565606059323 (patch)
tree9dbf8901e2a58cd3a690f04f68f157eba73c88fb /pkgs/servers
parent4fc0b4edca7e48755538d4436b98baff5901a752 (diff)
parent6d09fbfcf4a721317dd9a042db440887eb58b64b (diff)
downloadnixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar.gz
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar.bz2
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar.lz
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar.xz
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.tar.zst
nixlib-c6a8b90d153643ff5eaaa378b8db565606059323.zip
Merge pull request #34296 from fgaz/isso
Isso: init at 0.10.6 (plus dependencies)
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/isso/default.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/pkgs/servers/isso/default.nix b/pkgs/servers/isso/default.nix
new file mode 100644
index 000000000000..5aafe55512be
--- /dev/null
+++ b/pkgs/servers/isso/default.nix
@@ -0,0 +1,54 @@
+{ stdenv, python2, fetchurl, fetchFromGitHub }:
+
+let python = python2.override {
+  packageOverrides = self: super: {
+    misaka = super.misaka.overridePythonAttrs (old: rec {
+      version = "1.0.2";
+      src = old.src.override {
+        inherit version;
+        sha256 = "05rmjxlfhghj90m1kc55lx3z8igabw5y8wmly66p3hphdy4f95v1";
+      };
+      propagatedBuildInputs = [ ];
+    });
+    html5lib = super.html5lib.overridePythonAttrs (old: rec {
+      version = "0.9999999";
+      src = old.src.override {
+        inherit version;
+        sha256 = "2612a191a8d5842bfa057e41ba50bbb9dcb722419d2408c78cff4758d0754868";
+      };
+      checkInputs = with self; [ nose flake8 ];
+      propagatedBuildInputs = with self; [ six ];
+      checkPhase = ''
+        nosetests
+      '';
+    });
+  };
+};
+
+in with python.pkgs; buildPythonApplication rec {
+  pname = "isso";
+  version = "0.10.6";
+
+  # no tests on PyPI
+  src = fetchFromGitHub {
+    owner = "posativ";
+    repo = pname;
+    rev = version;
+    sha256 = "19x9xbwd15fikhchyl4i1wrqx589hdmh279xhnxdszrq898igywb";
+  };
+
+  propagatedBuildInputs = [ misaka werkzeug ipaddr configparser html5lib ];
+
+  checkInputs = [ nose ];
+
+  checkPhase = ''
+    ${python.interpreter} setup.py nosetests
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A commenting server similar to Disqus";
+    homepage = https://posativ.org/isso/;
+    license = licenses.mit;
+    maintainers = with maintainers; [ fgaz ];
+  };
+}