summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2018-09-17 09:41:16 -0400
committerworldofpeace <worldofpeace@users.noreply.github.com>2018-09-17 09:41:16 -0400
commitbd02b3352ae45cf0890d63409e7796894b75c44c (patch)
treef798e19e39a282583d8ca9deff6250fb8ebfc493 /pkgs/servers
parent61b2e0cba8d1faacd5ea80c6a332c1840412be19 (diff)
downloadnixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar.gz
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar.bz2
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar.lz
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar.xz
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.tar.zst
nixlib-bd02b3352ae45cf0890d63409e7796894b75c44c.zip
emby: 3.4.1.0 -> 3.5.2.0
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/emby/default.nix35
1 files changed, 22 insertions, 13 deletions
diff --git a/pkgs/servers/emby/default.nix b/pkgs/servers/emby/default.nix
index baeefc7ff9c8..11cb914bfd80 100644
--- a/pkgs/servers/emby/default.nix
+++ b/pkgs/servers/emby/default.nix
@@ -1,23 +1,32 @@
-{ stdenv, fetchurl, pkgs, unzip, sqlite, makeWrapper, mono54, ffmpeg, ... }:
+{ stdenv, fetchurl, unzip, sqlite, makeWrapper, mono54, ffmpeg }:
 
 stdenv.mkDerivation rec {
   name = "emby-${version}";
-  version = "3.4.1.0";
-
+  version = "3.5.2.0";
+
+  # We are fetching a binary here, however, a source build is possible.
+  # See -> https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=emby-server-git#n43
+  # Though in my attempt it failed with this error repeatedly
+  # The type 'Attribute' is defined in an assembly that is not referenced. You must add a reference to assembly 'netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51'.
+  # This may also need msbuild (instead of xbuild) which isn't in nixpkgs
+  # See -> https://github.com/NixOS/nixpkgs/issues/29817
   src = fetchurl {
-    url = "https://github.com/MediaBrowser/Emby/releases/download/${version}/Emby.Mono.zip";
-    sha256 = "08jr6v8xhmiwbby0lfvpjrlma280inwh5qp6v4p93lzd07fjynh5";
+    url = "https://github.com/MediaBrowser/Emby.Releases/releases/download/${version}/embyserver-mono_${version}.zip";
+    sha256 = "12f9skvnr9qxnrvr3q014yggfwvkpjk0ynbgf0fwk56h4kal7fx8";
   };
 
-  buildInputs = with pkgs; [
+  buildInputs = [
     unzip
     makeWrapper
   ];
-  propagatedBuildInputs = with pkgs; [
+
+  propagatedBuildInputs = [
     mono54
     sqlite
   ];
 
+  preferLocalBuild = true;
+
   # Need to set sourceRoot as unpacker will complain about multiple directory output
   sourceRoot = ".";
 
@@ -27,18 +36,18 @@ stdenv.mkDerivation rec {
   '';
 
   installPhase = ''
-    mkdir -p $out/bin
-    cp -r * $out/bin
+    mkdir -p "$out/bin"
+    cp -r * "$out/bin"
 
     makeWrapper "${mono54}/bin/mono" $out/bin/MediaBrowser.Server.Mono \
       --add-flags "$out/bin/MediaBrowser.Server.Mono.exe -ffmpeg ${ffmpeg}/bin/ffmpeg -ffprobe ${ffmpeg}/bin/ffprobe"
   '';
 
-  meta = {
+  meta =  with stdenv.lib; {
     description = "MediaBrowser - Bring together your videos, music, photos, and live television";
     homepage = https://emby.media/;
-    license = stdenv.lib.licenses.gpl2;
-    maintainers = [ stdenv.lib.maintainers.fadenb ];
-    platforms = stdenv.lib.platforms.all;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ fadenb ];
+    platforms = platforms.all;
   };
 }