summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMathijs Kwik <mathijs@bluescreen303.nl>2012-09-09 17:25:59 +0200
committerMathijs Kwik <mathijs@bluescreen303.nl>2012-09-09 17:25:59 +0200
commitad628ab557e87ce981566af5fe162f9aab2fe1b9 (patch)
tree43a6badc29a9049eafd878311936b7ed98823098 /pkgs/servers
parent071d685dda26a31f43a3278c94ec13523995f0ac (diff)
downloadnixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar.gz
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar.bz2
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar.lz
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar.xz
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.tar.zst
nixlib-ad628ab557e87ce981566af5fe162f9aab2fe1b9.zip
mongodb: fix build on i686, restrict platforms to linux
mongodb is supposed to work on most unixes but its build system is
quite picky and fragile.
As it hasn't worked for non-linux platforms on NixOS yet, this change
won't affect anyone and will remove the illusion that other platforms
are currently supported.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/mongodb/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/servers/nosql/mongodb/default.nix b/pkgs/servers/nosql/mongodb/default.nix
index 48a33377e506..ce664972037e 100644
--- a/pkgs/servers/nosql/mongodb/default.nix
+++ b/pkgs/servers/nosql/mongodb/default.nix
@@ -2,6 +2,12 @@
 
 with stdenv.lib;
 
+let installerPatch = fetchurl {
+      url = "https://jira.mongodb.org/secure/attachment/18160/SConscript.client.patch";
+      sha256 = "0n60fh2r8i7m6g113k0iw4adc8jv2by4ahrd780kxg47kzfgw06a";
+    };
+
+in
 stdenv.mkDerivation rec {
   name = "mongodb-2.2.0";
 
@@ -12,9 +18,11 @@ stdenv.mkDerivation rec {
 
   buildNativeInputs = [ scons which ];
 
+  patches = [ installerPatch ];
+
   enableParallelBuilding = true;
 
-  patchPhase = ''
+  postPatch = ''
     substituteInPlace SConstruct --replace "Environment( BUILD_DIR" "Environment( ENV = os.environ, BUILD_DIR"
   '' + optionalString useV8 ''
     substituteInPlace SConstruct --replace "#/../v8" "${v8}" \
@@ -37,6 +45,6 @@ stdenv.mkDerivation rec {
     license = "AGPLv3";
 
     maintainers = [ stdenv.lib.maintainers.bluescreen303 ];
-    platforms = stdenv.lib.platforms.all;
+    platforms = stdenv.lib.platforms.linux;
   };
 }