summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2017-11-17 14:03:30 +0100
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2017-11-17 14:03:30 +0100
commita2e40f72547a888066698a41fa54ca4c675aaad0 (patch)
tree6341531d74eb3a6fc744687a7144eb84fe58c053 /pkgs/servers
parent9826f5cc3cd9d1c2e31d8110952018bdf8f1a956 (diff)
downloadnixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar.gz
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar.bz2
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar.lz
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar.xz
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.tar.zst
nixlib-a2e40f72547a888066698a41fa54ca4c675aaad0.zip
nixpkgs/bind: use python3
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dns/bind/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/servers/dns/bind/default.nix b/pkgs/servers/dns/bind/default.nix
index c52761e66b6f..427497bff0f9 100644
--- a/pkgs/servers/dns/bind/default.nix
+++ b/pkgs/servers/dns/bind/default.nix
@@ -1,9 +1,9 @@
 { stdenv, lib, fetchurl, openssl, libtool, perl, libxml2
 , enableSeccomp ? false, libseccomp ? null
-, enablePython ? false, python ? null }:
+, enablePython ? false, python3 ? null }:
 
 assert enableSeccomp -> libseccomp != null;
-assert enablePython -> python != null;
+assert enablePython -> python3 != null;
 
 let version = "9.11.2"; in
 
@@ -22,7 +22,7 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ openssl libtool perl libxml2 ]
     ++ lib.optional enableSeccomp libseccomp
-    ++ lib.optional enablePython python;
+    ++ lib.optional enablePython python3;
 
   STD_CDEFINES = [ "-DDIG_SIGCHASE=1" ]; # support +sigchase