summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-01-24 09:29:16 +0200
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-01-24 10:03:35 +0200
commita1909d73800a520b34640693343da7b68d5b7294 (patch)
treefe12e921fa3b9939355ad2ae1ecf4b22ba3bb473 /pkgs/servers
parentb56b24f72909aaf156aae78390d8b4e5d21014ca (diff)
downloadnixlib-a1909d73800a520b34640693343da7b68d5b7294.tar
nixlib-a1909d73800a520b34640693343da7b68d5b7294.tar.gz
nixlib-a1909d73800a520b34640693343da7b68d5b7294.tar.bz2
nixlib-a1909d73800a520b34640693343da7b68d5b7294.tar.lz
nixlib-a1909d73800a520b34640693343da7b68d5b7294.tar.xz
nixlib-a1909d73800a520b34640693343da7b68d5b7294.tar.zst
nixlib-a1909d73800a520b34640693343da7b68d5b7294.zip
treewide: Mass replace 'glibc}/lib' to refer the 'out' output
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/plex/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/servers/plex/default.nix b/pkgs/servers/plex/default.nix
index 2aeb9379e10f..d88f7a89493d 100644
--- a/pkgs/servers/plex/default.nix
+++ b/pkgs/servers/plex/default.nix
@@ -27,12 +27,12 @@ stdenv.mkDerivation rec {
     # Now we need to patch up the executables and libraries to work on Nix.
     # Side note: PLEASE don't put spaces in your binary names. This is stupid.
     for bin in "Plex Media Server" "Plex DLNA Server" "Plex Media Scanner"; do
-      patchelf --set-interpreter "${glibc}/lib/ld-linux-x86-64.so.2" "$out/usr/lib/plexmediaserver/$bin"
+      patchelf --set-interpreter "${glibc.out}/lib/ld-linux-x86-64.so.2" "$out/usr/lib/plexmediaserver/$bin"
       patchelf --set-rpath "$out/usr/lib/plexmediaserver" "$out/usr/lib/plexmediaserver/$bin"
     done
 
     find $out/usr/lib/plexmediaserver/Resources -type f -a -perm -0100 \
-        -print -exec patchelf --set-interpreter "${glibc}/lib/ld-linux-x86-64.so.2" '{}' \;
+        -print -exec patchelf --set-interpreter "${glibc.out}/lib/ld-linux-x86-64.so.2" '{}' \;
 
     # executables need libstdc++.so.6
     ln -s "${stdenv.lib.makeLibraryPath [ stdenv.cc.cc ]}/libstdc++.so.6" "$out/usr/lib/plexmediaserver/libstdc++.so.6"