summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-11-13 15:53:10 -0800
committerWilliam A. Kennington III <william@wkennington.com>2015-11-13 15:53:10 -0800
commit9579c9ec7f53be31efba3803bd86661b59b0bb81 (patch)
treee9e9ec19c0989f18d96ec0b8c6faf3780eb3dfb1 /pkgs/servers
parent83aeb00a78ebca04bd6a42721284cad87da9fabe (diff)
parentcb21b77ff1b9ed006d1180ad7c94b2ee7ed3c096 (diff)
downloadnixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar.gz
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar.bz2
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar.lz
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar.xz
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.tar.zst
nixlib-9579c9ec7f53be31efba3803bd86661b59b0bb81.zip
Merge commit 'cb21b77' into master.upstream
This is a partial merge of staging for builds which are working
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/opensmtpd/default.nix7
-rw-r--r--pkgs/servers/mail/opensmtpd/extras.nix79
-rw-r--r--pkgs/servers/mail/opensmtpd/proc_path.diff76
-rw-r--r--pkgs/servers/search/elasticsearch/default.nix4
-rw-r--r--pkgs/servers/search/elasticsearch/es-home.patch13
-rw-r--r--pkgs/servers/sql/mariadb/default.nix22
-rw-r--r--pkgs/servers/x11/quartz-wm/default.nix3
-rw-r--r--pkgs/servers/x11/xorg/overrides.nix3
-rw-r--r--pkgs/servers/x11/xquartz/default.nix3
9 files changed, 33 insertions, 177 deletions
diff --git a/pkgs/servers/mail/opensmtpd/default.nix b/pkgs/servers/mail/opensmtpd/default.nix
index 2fd3f0421b97..a95a5d81ce95 100644
--- a/pkgs/servers/mail/opensmtpd/default.nix
+++ b/pkgs/servers/mail/opensmtpd/default.nix
@@ -4,18 +4,16 @@
 
 stdenv.mkDerivation rec {
   name = "opensmtpd-${version}";
-  version = "5.7.1p1";
+  version = "5.4.5p1";
 
   nativeBuildInputs = [ autoconf automake libtool bison ];
   buildInputs = [ libasr libevent zlib openssl db pam ];
 
   src = fetchurl {
     url = "http://www.opensmtpd.org/archives/${name}.tar.gz";
-    sha256 = "67e9dd9682ca8c181e84e66c76245a4a8f6205834f915a2c021cdfeb22049e3a";
+    sha256 = "15sicrpqsgg72igdckkwpmbgrapcjbfjsdrvm0zl8z13kgp6r4ks";
   };
 
-  patches = [ ./proc_path.diff ];
-
   configureFlags = [
     "--sysconfdir=/etc"
     "--localstatedir=/var"
@@ -26,7 +24,6 @@ stdenv.mkDerivation rec {
     "--with-privsep-user=smtpd"
     "--with-queue-user=smtpq"
     "--with-ca-file=/etc/ssl/certs/ca-certificates.crt"
-    "--with-libevent-dir=${libevent}"
   ];
 
   installFlags = [
diff --git a/pkgs/servers/mail/opensmtpd/extras.nix b/pkgs/servers/mail/opensmtpd/extras.nix
deleted file mode 100644
index 0123d19bf3fa..000000000000
--- a/pkgs/servers/mail/opensmtpd/extras.nix
+++ /dev/null
@@ -1,79 +0,0 @@
-{ stdenv, fetchurl, openssl, libevent, libasr,
-  python2, pkgconfig, lua5, perl, mariadb, postgresql, sqlite, hiredis }:
-stdenv.mkDerivation rec {
-  name = "opensmtpd-extras-${version}";
-  version = "5.7.1";
-
-  src = fetchurl {
-    url = "https://www.opensmtpd.org/archives/${name}.tar.gz";
-    sha256 = "1kld4hxgz792s0cb2gl7m2n618ikzqkj88w5dhaxdrxg4x2c4vdm";
-  };
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ openssl libevent
-    libasr python2 lua5 perl mariadb postgresql sqlite hiredis ];
-
-  configureFlags = [
-    "--sysconfdir=/etc"
-    "--localstatedir=/var"
-    "--with-privsep-user=smtpd"
-    "--with-libevent-dir=${libevent}"
-
-    "--with-filter-clamav"
-    "--with-filter-dkim-signer"
-    "--with-filter-dnsbl"
-    "--with-filter-monkey"
-    "--with-filter-pause"
-    "--with-filter-regex"
-    "--with-filter-spamassassin"
-    "--with-filter-stub"
-    "--with-filter-trace"
-    "--with-filter-void"
-    "--with-queue-null"
-    "--with-queue-ram"
-    "--with-queue-stub"
-    "--with-table-ldap"
-    "--with-table-socketmap"
-    "--with-table-passwd"
-    "--with-table-stub"
-    "--with-scheduler-ram"
-    "--with-scheduler-stub"
-
-  ] ++ stdenv.lib.optional (python2 != null) [
-    "--with-python=${python2}"
-    "--with-filter-python"
-    "--with-queue-python"
-    "--with-table-python"
-    "--with-scheduler-python"
-
-  ] ++ stdenv.lib.optional (lua5 != null) [
-    "--with-lua=${pkgconfig}"
-    "--with-filter-lua"
-
-  ] ++ stdenv.lib.optional (perl != null) [
-    "--with-perl=${perl}"
-    "--with-filter-perl"
-
-  ] ++ stdenv.lib.optional (mariadb != null) [
-    "--with-table-mysql"
-
-  ] ++ stdenv.lib.optional (postgresql != null) [
-    "--with-table-postgres"
-
-  ] ++ stdenv.lib.optional (sqlite != null) [
-    "--with-table-sqlite"
-
-  ] ++ stdenv.lib.optional (hiredis != null) [
-    "--with-table-redis"
-  ];
-
-  NIX_CFLAGS_COMPILE = stdenv.lib.optional (hiredis != null) [ "-I${hiredis}/include/hiredis" ];
-
-  meta = with stdenv.lib; {
-    homepage = https://www.opensmtpd.org/;
-    description = "Extra plugins for the OpenSMTPD mail server";
-    license = licenses.isc;
-    platforms = platforms.unix;
-    maintainers = with maintainers; [ gebner ];
-  };
-}
diff --git a/pkgs/servers/mail/opensmtpd/proc_path.diff b/pkgs/servers/mail/opensmtpd/proc_path.diff
deleted file mode 100644
index 0e8eac0bb83b..000000000000
--- a/pkgs/servers/mail/opensmtpd/proc_path.diff
+++ /dev/null
@@ -1,76 +0,0 @@
-diff -Naur opensmtpd-5.7.1p1/smtpd/parse.y opensmtpd-5.7.1p1.patched/smtpd/parse.y
---- opensmtpd-5.7.1p1/smtpd/parse.y	2015-06-30 10:13:34.000000000 +0200
-+++ opensmtpd-5.7.1p1.patched/smtpd/parse.y	2015-09-26 08:41:17.012472516 +0200
-@@ -2519,13 +2519,19 @@
- {
- 	struct filter_conf	*f;
- 	char			*path;
-+        const char              *proc_path;
- 
- 	if (dict_get(&conf->sc_filters, name)) {
- 		yyerror("filter \"%s\" already defined", name);
- 		return (NULL);
- 	}
- 
--	if (asprintf(&path, "%s/filter-%s", PATH_LIBEXEC, prog) == -1) {
-+        proc_path = getenv("OPENSMTPD_PROC_PATH");
-+        if (proc_path == NULL) {
-+                proc_path = PATH_LIBEXEC;
-+        }
-+
-+	if (asprintf(&path, "%s/filter-%s", proc_path, prog) == -1) {
- 		yyerror("filter \"%s\" asprintf failed", name);
- 		return (0);
- 	}
-diff -Naur opensmtpd-5.7.1p1/smtpd/smtpd.c opensmtpd-5.7.1p1.patched/smtpd/smtpd.c
---- opensmtpd-5.7.1p1/smtpd/smtpd.c	2015-06-30 10:13:34.000000000 +0200
-+++ opensmtpd-5.7.1p1.patched/smtpd/smtpd.c	2015-09-26 08:41:16.998472557 +0200
-@@ -854,6 +854,7 @@
- 	char		path[PATH_MAX];
- 	char		name[PATH_MAX];
- 	char		*arg;
-+        char            *proc_path;
- 
- 	if (strlcpy(name, conf, sizeof(name)) >= sizeof(name)) {
- 		log_warnx("warn: %s-proc: conf too long", key);
-@@ -864,7 +865,12 @@
- 	if (arg)
- 		*arg++ = '\0';
- 
--	if (snprintf(path, sizeof(path), PATH_LIBEXEC "/%s-%s", key, name) >=
-+        proc_path = getenv("OPENSMTPD_PROC_PATH");
-+        if (proc_path == NULL) {
-+                proc_path = PATH_LIBEXEC;
-+        }
-+
-+	if (snprintf(path, sizeof(path), "%s/%s-%s", proc_path, key, name) >=
- 	    (ssize_t)sizeof(path)) {
- 		log_warn("warn: %s-proc: exec path too long", key);
- 		return (-1);
-diff -Naur opensmtpd-5.7.1p1/smtpd/table.c opensmtpd-5.7.1p1.patched/smtpd/table.c
---- opensmtpd-5.7.1p1/smtpd/table.c	2015-06-30 10:13:34.000000000 +0200
-+++ opensmtpd-5.7.1p1.patched/smtpd/table.c	2015-09-26 08:41:17.005472536 +0200
-@@ -201,6 +201,7 @@
- 	struct table_backend	*tb;
- 	char			 buf[LINE_MAX];
- 	char			 path[LINE_MAX];
-+        const char              *proc_path;
- 	size_t			 n;
- 	struct stat		 sb;
- 
-@@ -215,8 +216,14 @@
- 	if (name && table_find(name, NULL))
- 		fatalx("table_create: table \"%s\" already defined", name);
- 
-+        proc_path = getenv("OPENSMTPD_PROC_PATH");
-+        if (proc_path == NULL) {
-+                proc_path = PATH_LIBEXEC;
-+        }
-+
- 	if ((tb = table_backend_lookup(backend)) == NULL) {
--		if ((size_t)snprintf(path, sizeof(path), PATH_LIBEXEC "/table-%s",
-+		if ((size_t)snprintf(path, sizeof(path), "%s/table-%s",
-+                    proc_path,
- 		    backend) >= sizeof(path)) {
- 			fatalx("table_create: path too long \""
- 			    PATH_LIBEXEC "/table-%s\"", backend);
diff --git a/pkgs/servers/search/elasticsearch/default.nix b/pkgs/servers/search/elasticsearch/default.nix
index 859f1501bb3c..16f010302902 100644
--- a/pkgs/servers/search/elasticsearch/default.nix
+++ b/pkgs/servers/search/elasticsearch/default.nix
@@ -3,11 +3,11 @@
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
-  name = "elasticsearch-1.5.2";
+  name = "elasticsearch-1.7.2";
 
   src = fetchurl {
     url = "https://download.elastic.co/elasticsearch/elasticsearch/${name}.tar.gz";
-    sha256 = "054s0k0y0g1x6wzbd6gmvrp5n89fqwqssbyhay0gmhvs6sbpibpg";
+    sha256 = "1lix4asvx1lbc227gzsrws3xqbcbqaal7v10w60kch0c4xg970bg";
   };
 
   patches = [ ./es-home.patch ];
diff --git a/pkgs/servers/search/elasticsearch/es-home.patch b/pkgs/servers/search/elasticsearch/es-home.patch
index 2f7a7fe79198..2f2018fd69fa 100644
--- a/pkgs/servers/search/elasticsearch/es-home.patch
+++ b/pkgs/servers/search/elasticsearch/es-home.patch
@@ -28,9 +28,10 @@ diff -rupN a/bin/plugin b/bin/plugin
  
  # make ELASTICSEARCH_HOME absolute
  ES_HOME=`cd "$ES_HOME"; pwd`
-@@ -45,4 +48,4 @@ while [ $# -gt 0 ]; do
-   shift
- done
- 
--exec "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home="$ES_HOME" $properties -cp "$ES_HOME/lib/*" org.elasticsearch.plugins.PluginManager $args
-+exec "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home="$ES_HOME" $properties -cp "$ES_CLASSPATH/lib/*" org.elasticsearch.plugins.PluginManager $args
+@@ -105,4 +105,4 @@
+
+ export HOSTNAME=`hostname -s`
+
+-eval "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home=\""$ES_HOME"\" $properties -cp \""$ES_HOME/lib/*"\" org.elasticsearch.plugins.PluginManager $args
+\ No newline at end of file
++eval "$JAVA" $JAVA_OPTS $ES_JAVA_OPTS -Xmx64m -Xms16m -Delasticsearch -Des.path.home="$ES_HOME" $properties -cp "$ES_CLASSPATH/lib/*" org.elasticsearch.plugins.PluginManager $args
diff --git a/pkgs/servers/sql/mariadb/default.nix b/pkgs/servers/sql/mariadb/default.nix
index df7721ca81e4..c758ef882696 100644
--- a/pkgs/servers/sql/mariadb/default.nix
+++ b/pkgs/servers/sql/mariadb/default.nix
@@ -1,19 +1,25 @@
-{ stdenv, fetchurl, cmake, ncurses, zlib, openssl, pcre, boost, judy, bison, libxml2
-, libaio, libevent, groff, jemalloc, perl, fixDarwinDylibNames, cctools
+{ stdenv, fetchurl, cmake, ncurses, zlib, xz, lzo, lz4, bzip2, snappy
+, openssl, pcre, boost, judy, bison, libxml2
+, libaio, libevent, groff, jemalloc, cracklib, systemd, numactl, perl
+, fixDarwinDylibNames, cctools
 }:
 
 with stdenv.lib;
 stdenv.mkDerivation rec {
   name = "mariadb-${version}";
-  version = "10.0.22";
+  version = "10.1.8";
 
   src = fetchurl {
     url    = "https://downloads.mariadb.org/interstitial/mariadb-${version}/source/mariadb-${version}.tar.gz";
-    sha256 = "0yzwv99s6smbmhs28pmdy01h23sdjxaa5k2m8n3rl1mprjmg85wy";
+    sha256 = "1yiv0161rkgll1yd9r1cb1wdx55rwynj8i623p6wjvda9536mgvw";
   };
 
-  buildInputs = [ cmake ncurses openssl zlib pcre libxml2 boost judy bison libevent ]
-    ++ stdenv.lib.optionals stdenv.isLinux [ jemalloc libaio ]
+  buildInputs = [
+    cmake ncurses openssl zlib xz lzo lz4 bzip2
+    # temporary due to https://mariadb.atlassian.net/browse/MDEV-9000
+    (if stdenv.is64bit then snappy else null)
+    pcre libxml2 boost judy bison libevent cracklib
+  ] ++ stdenv.lib.optionals stdenv.isLinux [ jemalloc libaio systemd numactl ]
     ++ stdenv.lib.optionals stdenv.isDarwin [ perl fixDarwinDylibNames cctools ];
 
   patches = stdenv.lib.optional stdenv.isDarwin ./my_context_asm.patch;
@@ -49,6 +55,8 @@ stdenv.mkDerivation rec {
     "-DWITH_PARTITION_STORAGE_ENGINE=1"
     "-DWITHOUT_EXAMPLE_STORAGE_ENGINE=1"
     "-DWITHOUT_FEDERATED_STORAGE_ENGINE=1"
+    "-DSECURITY_HARDENED=ON"
+    "-DWITH_WSREP=ON"
   ] ++ stdenv.lib.optionals stdenv.isDarwin [
     "-DWITHOUT_OQGRAPH_STORAGE_ENGINE=1"
     "-DWITHOUT_TOKUDB=1"
@@ -56,7 +64,7 @@ stdenv.mkDerivation rec {
   ];
 
   # fails to find lex_token.h sometimes
-  enableParallelBuilding = stdenv.isDarwin;
+  enableParallelBuilding = true;
 
   outputs = [ "out" "lib" ];
 
diff --git a/pkgs/servers/x11/quartz-wm/default.nix b/pkgs/servers/x11/quartz-wm/default.nix
index 5c9fe74b2ede..45e4df2bb8b9 100644
--- a/pkgs/servers/x11/quartz-wm/default.nix
+++ b/pkgs/servers/x11/quartz-wm/default.nix
@@ -21,6 +21,9 @@ in stdenv.mkDerivation {
     pkgconfig
     AppKit Xplugin
   ];
+  NIX_CFLAGS_COMPILE = "-F/System/Library/Frameworks -I/usr/include";
+  NIX_LDFLAGS = stdenv.lib.optional stdenv.isDarwin
+    "/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation";
   meta = with lib; {
     license = licenses.apsl20;
     platforms = platforms.darwin;
diff --git a/pkgs/servers/x11/xorg/overrides.nix b/pkgs/servers/x11/xorg/overrides.nix
index 1ef67a1aa8e5..1339e51eb232 100644
--- a/pkgs/servers/x11/xorg/overrides.nix
+++ b/pkgs/servers/x11/xorg/overrides.nix
@@ -360,6 +360,9 @@ in
           "--with-bundle-id-prefix=org.nixos.xquartz"
           "--with-sha1=CommonCrypto"
         ];
+        __impureHostDeps = ["/System/Library" "/usr"];
+        NIX_CFLAGS_COMPILE = "-F/System/Library/Frameworks -I/usr/include";
+        NIX_CFLAGS_LINK = "-L/usr/lib";
         preConfigure = ''
           ensureDir $out/Applications
           export NIX_CFLAGS_COMPILE="$NIX_CFLAGS_COMPILE -Wno-error"
diff --git a/pkgs/servers/x11/xquartz/default.nix b/pkgs/servers/x11/xquartz/default.nix
index cb84111c2c24..920b66147f26 100644
--- a/pkgs/servers/x11/xquartz/default.nix
+++ b/pkgs/servers/x11/xquartz/default.nix
@@ -109,8 +109,7 @@ in stdenv.mkDerivation {
 
     cp ${installer} $out/bin/xquartz-install
 
-    rm -rf $out/LaunchAgents
-    rm -rf $out/LaunchDaemons
+    rm -rf $out/LaunchAgents $out/LaunchDaemons
 
     fontsConfPath=$out/etc/X11/fonts.conf
     cp ${fontsConf} $fontsConfPath