summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorOrivej Desh <orivej@gmx.fr>2018-06-06 08:08:22 +0000
committerOrivej Desh <orivej@gmx.fr>2018-06-06 08:08:22 +0000
commit91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0 (patch)
tree935efe885634ce12695ef0d0fc3e350ff57b1aee /pkgs/servers
parentb29784b9e4b6ef31fe028a2dccc101355b5efb0f (diff)
parent07ebb8bb792be16de33596e2cea120eb72b2ec77 (diff)
downloadnixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar.gz
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar.bz2
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar.lz
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar.xz
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.tar.zst
nixlib-91e1ec684f051bd02e7a6f4f4ce0bd761f17dee0.zip
Merge branch 'master' into staging
* master: (63 commits)
  tests.cc-wrapper: do not test sanitizers on darwin
  nodePackages_8_x: Add nodejs (npm) to wrapper
  python.pkgs.cairocffi: support darwin
  osinfo-db: 20180514 -> 20180531 (#41532)
  pkcs11helper: 1.22 -> 1.23 (#41530)
  pmd: 6.3.0 -> 6.4.0 (#41529)
  renpy: 6.99.14.3 -> 7.0.0 (#41515)
  wireless-regdb: 2018.05.09 -> 2018.05.31 (#41502)
  gnuplot: 5.2.3 -> 5.2.4 (#41505)
  qrencode: 4.0.0 -> 4.0.1
  Revert "libbsd: replace with nbcompat"
  Revert "opendkim: fix libbsd dependency"
  Revert "libbsd-freedesktop: re-init at 0.9.1, use for samba"
  flent: fix fetchFromGitHub version
  syncthing: 0.14.47 -> 0.14.48
  pythonPackages.pykdtree: init at 1.3.0 (#41355)
  snd: 18.3 -> 18.4
  bat: support darwin
  faust2: fix build with llvm 5.0.2 (#40672)
  mc: 4.8.20 -> 4.8.21 (#41496)
  ...
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/home-assistant/component-packages.nix2
-rw-r--r--pkgs/servers/home-assistant/default.nix4
2 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/servers/home-assistant/component-packages.nix b/pkgs/servers/home-assistant/component-packages.nix
index 4d970a7e0d5d..e2acee87d1ab 100644
--- a/pkgs/servers/home-assistant/component-packages.nix
+++ b/pkgs/servers/home-assistant/component-packages.nix
@@ -228,7 +228,7 @@
     "comfoconnect" = ps: with ps; [  ];
     "config" = ps: with ps; [ aiohttp-cors ];
     "config.automation" = ps: with ps; [  ];
-    "config.config_entries" = ps: with ps; [  ];
+    "config.config_entries" = ps: with ps; [ voluptuous-serialize ];
     "config.core" = ps: with ps; [  ];
     "config.customize" = ps: with ps; [  ];
     "config.entity_registry" = ps: with ps; [  ];
diff --git a/pkgs/servers/home-assistant/default.nix b/pkgs/servers/home-assistant/default.nix
index 60b005ed54cc..fbc233398735 100644
--- a/pkgs/servers/home-assistant/default.nix
+++ b/pkgs/servers/home-assistant/default.nix
@@ -95,8 +95,8 @@ in with py.pkgs; buildPythonApplication rec {
   propagatedBuildInputs = [
     # From setup.py
     requests pyyaml pytz pip jinja2 voluptuous typing aiohttp async-timeout astral certifi attrs
-    # From http, frontend and recorder components
-    sqlalchemy aiohttp-cors hass-frontend
+    # From http, frontend, recorder and config.config_entries components
+    sqlalchemy aiohttp-cors hass-frontend voluptuous-serialize
   ] ++ componentBuildInputs ++ extraBuildInputs;
 
   checkInputs = [