summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorRoman Naumann <namor@hemio.de>2016-12-29 14:02:52 +0100
committerRoman Naumann <namor@hemio.de>2016-12-29 14:02:52 +0100
commit87ef766f6b1718136ec851237856d6f9fc578ccf (patch)
treec1a2214867019e97f6b0623592c9d71995bd5be9 /pkgs/servers
parent004eceb0f6c405515bc229c190d0da287fb51d94 (diff)
parent774435d0aa2c5e0cddb11a553ec1b1eaef748ed5 (diff)
downloadnixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar.gz
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar.bz2
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar.lz
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar.xz
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.tar.zst
nixlib-87ef766f6b1718136ec851237856d6f9fc578ccf.zip
Merge branch 'master' of github.com:nixos/nixpkgs into add_pkg_gorilla
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/atlassian/crowd.nix16
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix4
-rw-r--r--pkgs/servers/monitoring/prometheus/snmp-exporter.nix26
-rw-r--r--pkgs/servers/shellinabox/default.nix6
4 files changed, 46 insertions, 6 deletions
diff --git a/pkgs/servers/atlassian/crowd.nix b/pkgs/servers/atlassian/crowd.nix
index d84ddd00882b..05b88cf9cf3b 100644
--- a/pkgs/servers/atlassian/crowd.nix
+++ b/pkgs/servers/atlassian/crowd.nix
@@ -1,4 +1,5 @@
-{ stdenv, fetchurl, home ? "/var/lib/crowd" }:
+{ stdenv, fetchurl, home ? "/var/lib/crowd"
+, port ? 8092, proxyUrl ? null, openidPassword ? "WILL_NEVER_BE_SET" }:
 
 stdenv.mkDerivation rec {
   name = "atlassian-crowd-${version}";
@@ -18,9 +19,22 @@ stdenv.mkDerivation rec {
     rm -rf apache-tomcat/work
     ln -s /run/atlassian-crowd/work apache-tomcat/work
 
+    ln -s /run/atlassian-crowd/database database
+
     substituteInPlace apache-tomcat/bin/startup.sh --replace start run
 
     echo "crowd.home=${home}" > crowd-webapp/WEB-INF/classes/crowd-init.properties
+    substituteInPlace build.properties \
+      --replace "openidserver.url=http://localhost:8095/openidserver" \
+                "openidserver.url=http://localhost:${toString port}/openidserver"
+    substituteInPlace crowd-openidserver-webapp/WEB-INF/classes/crowd.properties \
+      --replace "http://localhost:8095/" \
+                "http://localhost:${toString port}/"
+    sed -r -i crowd-openidserver-webapp/WEB-INF/classes/crowd.properties \
+      -e 's,application.password\s+password,application.password ${openidPassword},'
+  '' + stdenv.lib.optionalString (proxyUrl != null) ''
+    sed -i crowd-openidserver-webapp/WEB-INF/classes/crowd.properties \
+      -e 's,http://localhost:${toString port}/openidserver,${proxyUrl}/openidserver,'
   '';
 
   installPhase = ''
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
index 5e87164c1b14..e9c1ec8b7242 100644
--- a/pkgs/servers/http/apache-httpd/2.4.nix
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -16,12 +16,12 @@ assert ldapSupport -> aprutil.ldapSupport && openldap != null;
 assert http2Support -> nghttp2 != null;
 
 stdenv.mkDerivation rec {
-  version = "2.4.23";
+  version = "2.4.25";
   name = "apache-httpd-${version}";
 
   src = fetchurl {
     url = "mirror://apache/httpd/httpd-${version}.tar.bz2";
-    sha256 = "0n2yx3gjlpr4kgqx845fj6amnmg25r2l6a7rzab5hxnpmar985hc";
+    sha256 = "1cl0bkqg6srb1sypga0cn8dcmdyxldavij73zmmkxvlz3kgw4zpq";
   };
 
   # FIXME: -dev depends on -doc
diff --git a/pkgs/servers/monitoring/prometheus/snmp-exporter.nix b/pkgs/servers/monitoring/prometheus/snmp-exporter.nix
new file mode 100644
index 000000000000..a52e1abad875
--- /dev/null
+++ b/pkgs/servers/monitoring/prometheus/snmp-exporter.nix
@@ -0,0 +1,26 @@
+{ stdenv, lib, go, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+  name = "snmp_exporter-${version}";
+  version = "0.1.0";
+  rev = "v${version}";
+
+  goPackagePath = "github.com/prometheus/snmp_exporter";
+
+  src = fetchFromGitHub {
+    inherit rev;
+    owner = "prometheus";
+    repo = "snmp_exporter";
+    sha256 = "1faa1gla5nqkhf1kq60v22bcph41qix3dn9db0w0fh2pkxpdxvrp";
+  };
+
+  doCheck = true;
+
+  meta = with stdenv.lib; {
+    description = "SNMP Exporter for Prometheus";
+    homepage = https://github.com/prometheus/snmp_exporter;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ oida ];
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/servers/shellinabox/default.nix b/pkgs/servers/shellinabox/default.nix
index c9f4e2d253f9..cad349c4b51f 100644
--- a/pkgs/servers/shellinabox/default.nix
+++ b/pkgs/servers/shellinabox/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, autoreconfHook, pam, openssl, openssh, shadow, makeWrapper }:
 
 stdenv.mkDerivation rec {
-  version = "2.19";
+  version = "2.20";
   name = "shellinabox-${version}";
 
   src = fetchFromGitHub {
     owner = "shellinabox";
     repo = "shellinabox";
-    rev = "1a8010f2c94a62e7398c4fa130dfe9e099dc55cd";
-    sha256 = "16cr7gbnh6vzsxlhg9j9avqrxbhbkqhsbvh197b0ccdwbb04ysan";
+    rev = "v${version}";
+    sha256 = "1hmfayh21cks2lyj572944ll0mmgsxbnj981b3hq3nhdg8ywzjfr";
   };
 
   patches = [ ./shellinabox-minus.patch ];