summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2015-08-21 21:12:25 +0300
committerVladimír Čunát <vcunat@gmail.com>2015-10-03 14:08:53 +0200
commit7cd13b9003da2dfe50e7fcf92933e5ae812d1701 (patch)
tree66e3c1ef3d09e2abc2cf62bb74142f5e9618dc66 /pkgs/servers
parentc856b13067a4a23e1800e7a17d8be6742fcac906 (diff)
downloadnixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar.gz
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar.bz2
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar.lz
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar.xz
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.tar.zst
nixlib-7cd13b9003da2dfe50e7fcf92933e5ae812d1701.zip
apache-httpd: Enable SSL via buildInputs
The old approach doesn't seem to work with multiple outputs.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
index 29f8a9621c9e..bcfd885ae012 100644
--- a/pkgs/servers/http/apache-httpd/2.4.nix
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -23,6 +23,7 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = [perl] ++
+    optional sslSupport openssl ++
     optional ldapSupport openldap ++    # there is no --with-ldap flag
     optional libxml2Support libxml2;
 
@@ -42,7 +43,7 @@ stdenv.mkDerivation rec {
     --enable-imagemap
     --enable-cgi
     ${optionalString proxySupport "--enable-proxy"}
-    ${optionalString sslSupport "--enable-ssl --with-ssl=${openssl}"}
+    ${optionalString sslSupport "--enable-ssl"}
     ${optionalString luaSupport "--enable-lua --with-lua=${lua5}"}
     ${optionalString libxml2Support "--with-libxml2=${libxml2}/include/libxml2"}
   '';