summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorMatthew Justin Bauer <mjbauer95@gmail.com>2018-03-22 11:11:17 -0500
committerGitHub <noreply@github.com>2018-03-22 11:11:17 -0500
commit779c25b2fe88e09c490925a85c00b1dacb98a829 (patch)
treedb64efe931e0a92a800b45c3da10c57ef0e525d4 /pkgs/servers
parente35105c7c872bb9708cfa1c24158a74f354ab5f8 (diff)
parent53682b90943e2b5387fcc92c1b7545ea52dbd527 (diff)
downloadnixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar.gz
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar.bz2
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar.lz
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar.xz
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.tar.zst
nixlib-779c25b2fe88e09c490925a85c00b1dacb98a829.zip
Merge pull request #34053 from thpham/serviio
serviio: init at 1.9
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/serviio/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/servers/serviio/default.nix b/pkgs/servers/serviio/default.nix
new file mode 100644
index 000000000000..876cc01592e9
--- /dev/null
+++ b/pkgs/servers/serviio/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "serviio-${version}";
+  version = "1.9";
+
+  src = fetchurl {
+    url = "http://download.serviio.org/releases/${name}-linux.tar.gz";
+    sha256 = "0vi9dwpdrk087gpi0xib0hwpvdmaf9g99nfdfx2r3wmmdzw7wysl";
+  };
+
+  phases = ["unpackPhase" "installPhase"];
+
+  installPhase = ''
+    mkdir -p $out
+    cp -R config legal lib library plugins LICENCE.txt NOTICE.txt README.txt RELEASE_NOTES.txt $out
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://serviio.org;
+    description = "UPnP Media Streaming Server";
+    longDescription = ''
+      Serviio is a free media server. It allows you to stream your media files (music, video or images)
+      to any DLNA-certified renderer device (e.g. a TV set, Bluray player, games console) on your home network.
+    '';
+    license = licenses.unfree;
+    maintainers = [ maintainers.thpham ];
+    platforms = platforms.linux;
+  };
+}
\ No newline at end of file