summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-12-05 13:15:41 +0100
committerVladimír Čunát <vcunat@gmail.com>2015-12-05 13:16:55 +0100
commit6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27 (patch)
treedc3d7bda09cb85a7cfaafa42390952175b7726db /pkgs/servers
parent2709a815e54795efd38508a3e4db66502e742d55 (diff)
downloadnixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar.gz
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar.bz2
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar.lz
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar.xz
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.tar.zst
nixlib-6cc57be289c32fb6a8b5859a9d46ed2d1c5e9c27.zip
apache modules: fix build problems
pkgs.mod_evasive was removed, because that combination isn't supported
(according to an assertion).
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/apache-httpd/2.2.nix7
-rw-r--r--pkgs/servers/http/apache-httpd/2.4.nix4
-rw-r--r--pkgs/servers/http/apache-modules/mod_fastcgi/default.nix2
3 files changed, 9 insertions, 4 deletions
diff --git a/pkgs/servers/http/apache-httpd/2.2.nix b/pkgs/servers/http/apache-httpd/2.2.nix
index 5ae4cfdaaf1f..bb4fa9782d6a 100644
--- a/pkgs/servers/http/apache-httpd/2.2.nix
+++ b/pkgs/servers/http/apache-httpd/2.2.nix
@@ -24,7 +24,8 @@ stdenv.mkDerivation rec {
   outputs = [ "dev" "out" "doc" ];
   setOutputFlags = false; # it would move $out/modules, etc.
 
-  buildInputs = [ pkgconfig perl apr aprutil pcre zlib ] ++
+  propagatedBuildInputs = [ apr ]; # otherwise mod_* fail to find includes often
+  buildInputs = [ pkgconfig perl aprutil pcre zlib ] ++
     stdenv.lib.optional sslSupport openssl;
 
   # Required for ‘pthread_cancel’.
@@ -34,6 +35,9 @@ stdenv.mkDerivation rec {
     sed -i config.layout -e "s|installbuilddir:.*|installbuilddir: $dev/share/build|"
   '';
 
+  preConfigure = ''
+    configureFlags="$configureFlags --includedir=$dev/include"
+  '';
   configureFlags = ''
     --with-z=${zlib}
     --with-pcre=${pcre}
@@ -47,7 +51,6 @@ stdenv.mkDerivation rec {
     --enable-disk-cache
     --enable-file-cache
     --enable-mem-cache
-    --includedir=$(dev)/include
     --docdir=$(doc)/share/doc
   '';
 
diff --git a/pkgs/servers/http/apache-httpd/2.4.nix b/pkgs/servers/http/apache-httpd/2.4.nix
index 9049b0122fd7..fe60fe2c87dc 100644
--- a/pkgs/servers/http/apache-httpd/2.4.nix
+++ b/pkgs/servers/http/apache-httpd/2.4.nix
@@ -39,6 +39,9 @@ stdenv.mkDerivation rec {
   # Required for ‘pthread_cancel’.
   NIX_LDFLAGS = stdenv.lib.optionalString (!stdenv.isDarwin) "-lgcc_s";
 
+  preConfigure = ''
+    configureFlags="$configureFlags --includedir=$dev/include"
+  '';
   configureFlags = ''
     --with-apr=${apr}
     --with-apr-util=${aprutil}
@@ -55,7 +58,6 @@ stdenv.mkDerivation rec {
     ${optionalString sslSupport "--enable-ssl"}
     ${optionalString luaSupport "--enable-lua --with-lua=${lua5}"}
     ${optionalString libxml2Support "--with-libxml2=${libxml2.dev}/include/libxml2"}
-    --includedir=$(dev)/include
     --docdir=$(doc)/share/doc
   '';
 
diff --git a/pkgs/servers/http/apache-modules/mod_fastcgi/default.nix b/pkgs/servers/http/apache-modules/mod_fastcgi/default.nix
index e70c3105408f..178900570d07 100644
--- a/pkgs/servers/http/apache-modules/mod_fastcgi/default.nix
+++ b/pkgs/servers/http/apache-modules/mod_fastcgi/default.nix
@@ -20,7 +20,7 @@ stdenv.mkDerivation rec {
 
   preBuild = ''
     cp Makefile.AP2 Makefile
-    makeFlags="top_dir=${apacheHttpd} prefix=$out"
+    makeFlags="top_dir=${apacheHttpd}/share prefix=$out"
   '';
 
   meta = {