summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-10-14 10:36:13 +0200
committerVladimír Čunát <vcunat@gmail.com>2017-10-14 10:36:13 +0200
commit6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9 (patch)
tree5345763c864b43c0a746fa7c1b75a5a4af86fda4 /pkgs/servers
parent2a4f47dd1a32daab2b6fdd5e1db249fa36918e43 (diff)
parent2fdfefa2da9fd2a2dd35d7aa00dfbc55ab0d5bcc (diff)
downloadnixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar.gz
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar.bz2
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar.lz
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar.xz
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.tar.zst
nixlib-6525c22ef1c23ec1ccd64af46a8bb7ae449aa0c9.zip
Merge branch 'master' into staging
Hydra: ?compare=1401528
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/eventstore/default.nix7
-rw-r--r--pkgs/servers/plex/default.nix6
2 files changed, 7 insertions, 6 deletions
diff --git a/pkgs/servers/nosql/eventstore/default.nix b/pkgs/servers/nosql/eventstore/default.nix
index 572cfe1f17d6..e6bf634b554c 100644
--- a/pkgs/servers/nosql/eventstore/default.nix
+++ b/pkgs/servers/nosql/eventstore/default.nix
@@ -1,16 +1,16 @@
-{ stdenv, fetchFromGitHub, fetchpatch, mono, v8 }:
+{ stdenv, fetchFromGitHub, fetchpatch, git, mono, v8 }:
 
 # There are some similarities with the pinta derivation. We should
 # have a helper to make it easy to package these Mono apps.
 
 stdenv.mkDerivation rec {
   name = "EventStore-${version}";
-  version = "3.5.0";
+  version = "4.0.3";
   src = fetchFromGitHub {
     owner  = "EventStore";
     repo   = "EventStore";
     rev    = "oss-v${version}";
-    sha256 = "0dp5914hxwdzw62q49wavqfqkw3jy0dvml09y7gh8frnbiajcxq9";
+    sha256 = "1905bnqyyiqprva67cp49rgib324iipw2l71jzj0ynzi7kxr4mgg";
   };
 
   buildPhase = ''
@@ -33,6 +33,7 @@ stdenv.mkDerivation rec {
     chmod +x $out/bin/clusternode
   '';
 
+  nativeBuildInputs = [ git ];
   buildInputs = [ v8 mono ];
 
   phases = [ "unpackPhase" "buildPhase" "installPhase" ];
diff --git a/pkgs/servers/plex/default.nix b/pkgs/servers/plex/default.nix
index 317466897194..fa944f5fd26d 100644
--- a/pkgs/servers/plex/default.nix
+++ b/pkgs/servers/plex/default.nix
@@ -6,9 +6,9 @@
 let
   plexPass = throw "Plex pass has been removed at upstream's request; please unset nixpkgs.config.plex.pass";
   plexpkg = if enablePlexPass then plexPass else {
-    version = "1.9.2.4285";
-    vsnHash = "9f65b88ae";
-    sha256 = "0rz53kb4r32s734jhb3n65dcmb0mylhb6wcqinp0dg8w39ncv571";
+    version = "1.9.5.4339";
+    vsnHash = "46276db8d";
+    sha256 = "09zc2wfpvan2j9h88x1f57lpfiqvml2m5m2azhphi4hb31sd3hch";
   };
 
 in stdenv.mkDerivation rec {