summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2018-11-07 00:05:22 +0100
committerGitHub <noreply@github.com>2018-11-07 00:05:22 +0100
commit6141939d6e0a77c84905efd560c03c3032164ef1 (patch)
tree57930c5d117d67174ca6ba7f2219549eb4c2c116 /pkgs/servers
parent13892da3e76351e0a280fa390e8cb49b1b8b9265 (diff)
parent02e1f00ffdd0c1a74fbc0be5f314b8921b0c9165 (diff)
downloadnixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar.gz
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar.bz2
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar.lz
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar.xz
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.tar.zst
nixlib-6141939d6e0a77c84905efd560c03c3032164ef1.zip
Merge pull request #44439 from Ekleog/meta-tests
[RFC] Use `meta.tests` to link from packages to the tests that test them
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/dovecot/default.nix4
-rw-r--r--pkgs/servers/mail/opensmtpd/default.nix5
2 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/servers/mail/dovecot/default.nix b/pkgs/servers/mail/dovecot/default.nix
index 3e628f876dd7..638393bd356a 100644
--- a/pkgs/servers/mail/dovecot/default.nix
+++ b/pkgs/servers/mail/dovecot/default.nix
@@ -1,6 +1,7 @@
 { stdenv, lib, fetchurl, perl, pkgconfig, systemd, openssl
 , bzip2, zlib, lz4, inotify-tools, pam, libcap
 , clucene_core_2, icu, openldap, libsodium, libstemmer, cyrus_sasl
+, nixosTests
 # Auth modules
 , withMySQL ? false, mysql
 , withPgSQL ? false, postgresql
@@ -74,5 +75,8 @@ stdenv.mkDerivation rec {
     description = "Open source IMAP and POP3 email server written with security primarily in mind";
     maintainers = with stdenv.lib.maintainers; [ peti rickynils fpletz ];
     platforms = stdenv.lib.platforms.unix;
+    tests = {
+      opensmtpd-interaction = nixosTests.opensmtpd;
+    };
   };
 }
diff --git a/pkgs/servers/mail/opensmtpd/default.nix b/pkgs/servers/mail/opensmtpd/default.nix
index d55804504442..236e1dba181e 100644
--- a/pkgs/servers/mail/opensmtpd/default.nix
+++ b/pkgs/servers/mail/opensmtpd/default.nix
@@ -1,5 +1,5 @@
 { stdenv, lib, fetchurl, fetchpatch, autoconf, automake, libtool, bison
-, libasr, libevent, zlib, libressl, db, pam
+, libasr, libevent, zlib, libressl, db, pam, nixosTests
 }:
 
 stdenv.mkDerivation rec {
@@ -61,5 +61,8 @@ stdenv.mkDerivation rec {
     license = licenses.isc;
     platforms = platforms.linux;
     maintainers = with maintainers; [ rickynils obadz ekleog ];
+    tests = {
+      basic-functionality-and-dovecot-interaction = nixosTests.opensmtpd;
+    };
   };
 }