summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJohn Boehr <jbboehr@gmail.com>2018-04-15 12:15:26 -0700
committerJohn Boehr <jbboehr@gmail.com>2018-04-15 12:15:26 -0700
commit4707e69aac4456a19611a3754bd1f0c5251113e5 (patch)
tree545d0c0c881bd4f911ade66b2d3f67607d35b291 /pkgs/servers
parent0b307aa73804bbd7a7172899e59ae0b8c347a62d (diff)
downloadnixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar.gz
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar.bz2
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar.lz
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar.xz
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.tar.zst
nixlib-4707e69aac4456a19611a3754bd1f0c5251113e5.zip
Incorporate libedit changes from #38968
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/cockroachdb/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/servers/sql/cockroachdb/default.nix b/pkgs/servers/sql/cockroachdb/default.nix
index 65d2dd17528c..aba997d75f13 100644
--- a/pkgs/servers/sql/cockroachdb/default.nix
+++ b/pkgs/servers/sql/cockroachdb/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildGoPackage, fetchurl, cmake, xz, which, autoconf, ncurses6 }:
+{ stdenv, buildGoPackage, fetchurl, cmake, xz, which, autoconf, ncurses6, libedit }:
 
 buildGoPackage rec {
   name = "cockroach-${version}";
@@ -11,7 +11,7 @@ buildGoPackage rec {
     sha256 = "0x8hf5qwvgb2w6dcnvy20v77nf19f0l1pb40jf31rm72xhk3bwvy";
   };
 
-  buildInputs = [ ncurses6 ];
+  buildInputs = [ (if stdenv.isDarwin then libedit else ncurses6) ];
   nativeBuildInputs = [ cmake xz which autoconf ];
 
   buildPhase = ''