summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-11-22 15:23:37 -0500
committerGitHub <noreply@github.com>2017-11-22 15:23:37 -0500
commit405412dfd9394fc25680baa9d1d6296ba4ad91c4 (patch)
tree7507d67fed0ff963b1fa8928a29be80bb51cc1c9 /pkgs/servers
parent9ae72f2715d800f25f7dca0dec69624968d52909 (diff)
parentda19c34d0fd335424e734c3bec9ca87687eb15f0 (diff)
downloadnixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar.gz
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar.bz2
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar.lz
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar.xz
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.tar.zst
nixlib-405412dfd9394fc25680baa9d1d6296ba4ad91c4.zip
Merge pull request #31775 from obsidiansystems/stdenv-both-propagated-files
stdenv setup: Always use both propagated files
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/munin/default.nix4
-rw-r--r--pkgs/servers/x11/xorg/builder.sh26
2 files changed, 13 insertions, 17 deletions
diff --git a/pkgs/servers/monitoring/munin/default.nix b/pkgs/servers/monitoring/munin/default.nix
index 7882572b6c88..da6c98371689 100644
--- a/pkgs/servers/monitoring/munin/default.nix
+++ b/pkgs/servers/monitoring/munin/default.nix
@@ -102,8 +102,8 @@ stdenv.mkDerivation rec {
     find "$out/lib/plugins" -type f -print0 | xargs -0 -L1 \
         sed -i -e "s|/usr/bin/||g" -e "s|/usr/sbin/||g" -e "s|\<bc\>|${bc}/bin/bc|g"
 
-    if test -e $out/nix-support/propagated-native-build-inputs; then
-        ln -s $out/nix-support/propagated-native-build-inputs $out/nix-support/propagated-user-env-packages
+    if test -e $out/nix-support/propagated-build-inputs; then
+        ln -s $out/nix-support/propagated-build-inputs $out/nix-support/propagated-user-env-packages
     fi
 
     for file in "$out"/bin/munindoc "$out"/sbin/munin-* "$out"/lib/munin-* "$out"/www/cgi/*; do
diff --git a/pkgs/servers/x11/xorg/builder.sh b/pkgs/servers/x11/xorg/builder.sh
index fae8bf5a8ce5..bb3e5ac42832 100644
--- a/pkgs/servers/x11/xorg/builder.sh
+++ b/pkgs/servers/x11/xorg/builder.sh
@@ -16,22 +16,18 @@ postInstall() {
 
     echo "propagating requisites $requires"
 
+    if test -n "$crossConfig"; then
+        local pkgs=("${crossPkgs[@]}")
+    else
+        local pkgs=("${nativePkgs[@]}")
+    fi
     for r in $requires; do
-        if test -n "$crossConfig"; then
-            for p in "${crossPkgs[@]}"; do
-                if test -e $p/lib/pkgconfig/$r.pc; then
-                    echo "  found requisite $r in $p"
-                    propagatedBuildInputs="$propagatedBuildInputs $p"
-                fi
-            done
-        else
-            for p in "${nativePkgs[@]}"; do
-                if test -e $p/lib/pkgconfig/$r.pc; then
-                    echo "  found requisite $r in $p"
-                    propagatedNativeBuildInputs="$propagatedNativeBuildInputs $p"
-                fi
-            done
-        fi
+        for p in "${pkgs[@]}"; do
+            if test -e $p/lib/pkgconfig/$r.pc; then
+                echo "  found requisite $r in $p"
+                propagatedBuildInputs+=" $p"
+            fi
+        done
     done
 }