summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-05-20 18:23:12 +0100
committerGitHub <noreply@github.com>2017-05-20 18:23:12 +0100
commit2a42b451059944f59021306af43fb035463290d1 (patch)
treee5b46a25cde7ac579ed3e53ce996e2e380fd6af0 /pkgs/servers
parent56835b1eeaa420b40917e8f5303ee834bf8fa098 (diff)
parentf3dce2cbda6e62940c606055d5fcb46b17fb436b (diff)
downloadnixlib-2a42b451059944f59021306af43fb035463290d1.tar
nixlib-2a42b451059944f59021306af43fb035463290d1.tar.gz
nixlib-2a42b451059944f59021306af43fb035463290d1.tar.bz2
nixlib-2a42b451059944f59021306af43fb035463290d1.tar.lz
nixlib-2a42b451059944f59021306af43fb035463290d1.tar.xz
nixlib-2a42b451059944f59021306af43fb035463290d1.tar.zst
nixlib-2a42b451059944f59021306af43fb035463290d1.zip
Merge pull request #25103 from Hodapp87/google_cloud_print
cloud-print-connector: init at unstable-2017-01-19
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/cloud-print-connector/default.nix35
-rw-r--r--pkgs/servers/cloud-print-connector/deps.nix57
2 files changed, 92 insertions, 0 deletions
diff --git a/pkgs/servers/cloud-print-connector/default.nix b/pkgs/servers/cloud-print-connector/default.nix
new file mode 100644
index 000000000000..3a28368cc81c
--- /dev/null
+++ b/pkgs/servers/cloud-print-connector/default.nix
@@ -0,0 +1,35 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.0
+{ stdenv, buildGoPackage, fetchFromGitHub, avahi, cups }:
+
+# TODO: Add a service for gcp-cups-connector and perhaps some other
+# kind of configuration for the same thing that gcp-connector-util
+# provides.
+
+buildGoPackage rec {
+  name = "cloud-print-connector-unstable-${version}";
+  version = "1.11";
+  rev = "481ad139cc023a3ba65e769f08f277368fa8a5de";
+
+  goPackagePath = "github.com/google/cloud-print-connector";
+
+  src = fetchFromGitHub {
+    owner = "google";
+    repo = "cloud-print-connector";
+    sha256 = "1vryhhv92bsncy1bsx9j4graz3sz9ddmizakv2fdrns09mmcgchm";
+    rev = "v${version}";
+  };
+
+  goDeps = ./deps.nix;
+
+  buildInputs = [ avahi cups ];
+
+  meta = with stdenv.lib; {
+    description = "Share printers from your Windows, Linux, FreeBSD or OS X computer with ChromeOS and Android devices, using the Cloud Print Connector";
+    homepage = https://github.com/google/cloud-print-connector;
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ hodapp ];
+    # TODO: Fix broken build on OS X.  The GitHub presently lists the
+    # FreeBSD build as broken too, but this may change in the future.
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/servers/cloud-print-connector/deps.nix b/pkgs/servers/cloud-print-connector/deps.nix
new file mode 100644
index 000000000000..67901bdffeef
--- /dev/null
+++ b/pkgs/servers/cloud-print-connector/deps.nix
@@ -0,0 +1,57 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.0
+[
+  {
+    goPackagePath = "github.com/coreos/go-systemd";
+    fetch = {
+      type = "git";
+      url = "https://github.com/coreos/go-systemd";
+      rev = "1f9909e51b2dab2487c26d64c8f2e7e580e4c9f5";
+      sha256 = "1cc76wcmnyhhhi03dsc11lmxjwkzy09k3zx3h78bg05z8lhry4vn";
+    };
+  }
+  {
+    goPackagePath = "github.com/urfave/cli";
+    fetch = {
+      type = "git";
+      url = "https://github.com/urfave/cli";
+      rev = "d70f47eeca3afd795160003bc6e28b001d60c67c";
+      sha256 = "1xm203qp4sdlvffcbag7v6mc2d6q61i25iiz3y9yqpy25jpcpgif";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/net";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/net";
+      rev = "513929065c19401a1c7b76ecd942f9f86a0c061b";
+      sha256 = "19ziin0k3n45nccjbk094f61hr198wzqnas93cmcxdja8f8fz27q";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/oauth2";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/oauth2";
+      rev = "f047394b6d14284165300fd82dad67edb3a4d7f6";
+      sha256 = "1l1a2iz1nmfmzzbjj1h8066prag4jvjqh13iv1jdlh05fgv6769i";
+    };
+  }
+  {
+    goPackagePath = "launchpad.net/go-xdg/v0";
+    fetch = {
+      type = "bzr";
+      url = "http://bazaar.launchpad.net/~chipaca/go-xdg/v0/";
+      rev = "10";
+      sha256 = "0fd68kkxzxjanpgannpys962bxzqdf8c1qvzk687hv504a3dp76f";
+    };
+  }
+  {
+    goPackagePath = "github.com/satori/go.uuid";
+    fetch = {
+      type = "git";
+      url = "https://github.com/satori/go.uuid";
+      rev = "879c5887cd475cd7864858769793b2ceb0d44feb";
+      sha256 = "1nbydsmjr60904kz5d46nib0zid5kcv4gk9wayi44gn5wlzz80zp";
+    };
+  }
+ ]