summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-10-14 05:47:54 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-10-28 10:09:32 +0100
commit261961c97dfe4085eec1f7b4a902198fc3d8ddeb (patch)
treea5092db14c4cd0ce90f35fd7f280a535e8c8048c /pkgs/servers
parent04c7506f0f9f47f3f38c3d5dff7b8dabc36368b6 (diff)
downloadnixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar.gz
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar.bz2
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar.lz
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar.xz
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.tar.zst
nixlib-261961c97dfe4085eec1f7b4a902198fc3d8ddeb.zip
postgresql: split and fixup some referrers
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/default.nix16
1 files changed, 12 insertions, 4 deletions
diff --git a/pkgs/servers/sql/postgresql/default.nix b/pkgs/servers/sql/postgresql/default.nix
index cf4519a82327..09f3997fa14b 100644
--- a/pkgs/servers/sql/postgresql/default.nix
+++ b/pkgs/servers/sql/postgresql/default.nix
@@ -10,7 +10,8 @@ let
       inherit sha256;
     };
 
-    outputs = [ "out" "doc" ];
+    outputs = [ "out" "lib" "doc" ];
+    setOutputFlags = false; # $out retains configureFlags :-/
 
     buildInputs =
       [ zlib readline openssl ]
@@ -20,8 +21,11 @@ let
 
     makeFlags = [ "world" ];
 
-    configureFlags =
-      [ "--with-openssl" ]
+    configureFlags = [
+      "--with-openssl"
+      "--sysconfdir=/etc"
+      "--libdir=$(lib)/lib"
+    ]
       ++ lib.optional (stdenv.isDarwin)  "--with-uuid=e2fs"
       ++ lib.optional (!stdenv.isDarwin) "--with-ossp-uuid";
 
@@ -36,8 +40,12 @@ let
 
     postInstall =
       ''
+        _moveToOutput "lib/pgxs" "$out" # looks strange, but not deleting it
+        _moveToOutput "lib/*.a" "$out"
+        _moveToOutput "lib/libecpg*" "$out"
+
         # Prevent a retained dependency on gcc-wrapper.
-        substituteInPlace $out/lib/pgxs/src/Makefile.global --replace ${stdenv.cc}/bin/ld ld
+        substituteInPlace "$out/lib/pgxs/src/Makefile.global" --replace ${stdenv.cc}/bin/ld ld
       '';
 
     disallowedReferences = [ stdenv.cc ];