summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2015-11-03 15:19:10 +0100
committerJoachim Fasting <joachifm@fastmail.fm>2015-11-03 15:22:50 +0100
commit2456dd0246cc762345984c73eab76a480c1e2d9f (patch)
tree2aaef5e62c4421384a9aaa348ab0cc7d04d18999 /pkgs/servers
parent4a6c595b0f1b78f14fef237831d3c6946efe1160 (diff)
downloadnixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar.gz
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar.bz2
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar.lz
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar.xz
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.tar.zst
nixlib-2456dd0246cc762345984c73eab76a480c1e2d9f.zip
hyperdex: blindly fix hashes of local dependencies
This patch blindly fixes the source archive checksums for the local dependencies
of hyperdex. I have not looked into why those hashes changed, but I have
verified that the hyperdex package now builds successfully.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/nosql/hyperdex/busybee.nix2
-rw-r--r--pkgs/servers/nosql/hyperdex/default.nix2
-rw-r--r--pkgs/servers/nosql/hyperdex/hyperleveldb.nix2
-rw-r--r--pkgs/servers/nosql/hyperdex/libe.nix4
-rw-r--r--pkgs/servers/nosql/hyperdex/libmacaroons.nix6
-rw-r--r--pkgs/servers/nosql/hyperdex/libpo6.nix2
-rw-r--r--pkgs/servers/nosql/hyperdex/replicant.nix6
7 files changed, 12 insertions, 12 deletions
diff --git a/pkgs/servers/nosql/hyperdex/busybee.nix b/pkgs/servers/nosql/hyperdex/busybee.nix
index 9fdbbf064b05..653c74bdabe4 100644
--- a/pkgs/servers/nosql/hyperdex/busybee.nix
+++ b/pkgs/servers/nosql/hyperdex/busybee.nix
@@ -7,7 +7,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://github.com/rescrv/busybee/archive/releases/${version}.zip";
-    sha256 = "0gr5h2j9rzwarblgcgddnxj39i282rvgn9vqlrcd60dx8c4dkm29";
+    sha256 = "0b51h1kmkf0s3d9y7wjqgp1pk1rk9i7n8bcgyj01kflzdgafbl0b";
   };
   buildInputs = [
     autoconf
diff --git a/pkgs/servers/nosql/hyperdex/default.nix b/pkgs/servers/nosql/hyperdex/default.nix
index 659081281ef0..3986e49c4bcf 100644
--- a/pkgs/servers/nosql/hyperdex/default.nix
+++ b/pkgs/servers/nosql/hyperdex/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://github.com/rescrv/HyperDex/archive/releases/${version}.zip";
-    sha256 = "0s1capy2hj45f5rmdb4fk0wxy7vz69krplhba57f6wrkpcz1zb57";
+    sha256 = "0l7w3x6c4nslz5ijmj8xys0k1slwi3s4crxmi16ml1x32bqgzhj7";
   };
 
   buildInputs = [
diff --git a/pkgs/servers/nosql/hyperdex/hyperleveldb.nix b/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
index c39f618f6cb1..f57bbe4f4d24 100644
--- a/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
+++ b/pkgs/servers/nosql/hyperdex/hyperleveldb.nix
@@ -6,7 +6,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://github.com/rescrv/HyperLevelDB/archive/releases/${version}.zip";
-    sha256 = "0xrzhwkrm7f2wz3jn4iqn1dim2pmgjhmpb1fy23fwa06v0q18hw8";
+    sha256 = "0m5fwl9sc7c6m2zm3zjlxxg7f602gnaryikxgflahhdccdvvr56y";
   };
   buildInputs = [ unzip autoconf automake libtool ];
   preConfigure = "autoreconf -i";
diff --git a/pkgs/servers/nosql/hyperdex/libe.nix b/pkgs/servers/nosql/hyperdex/libe.nix
index cc5232e13f22..f7e0d834bb44 100644
--- a/pkgs/servers/nosql/hyperdex/libe.nix
+++ b/pkgs/servers/nosql/hyperdex/libe.nix
@@ -5,8 +5,8 @@ stdenv.mkDerivation rec {
   version = "0.8.1";
 
   src = fetchurl {
-    url = "https://github.com/rescrv/e/archive/releases/0.8.1.zip";
-    sha256 = "1l13axsi52j2qaxbdnszdvfxksi7rwm2j1rrf0nlh990m6a3yg3s";
+    url = "https://github.com/rescrv/e/archive/releases/${version}.zip";
+    sha256 = "18xm0hcnqdf0ipfn19jrgzqsxij5xjbbnihhzc57n4v7yfdca1w3";
   };
   buildInputs = [ unzip autoconf automake libtool libpo6 pkgconfig ];
   preConfigure = "autoreconf -i";
diff --git a/pkgs/servers/nosql/hyperdex/libmacaroons.nix b/pkgs/servers/nosql/hyperdex/libmacaroons.nix
index 5d91a82a8ec6..719b18db8681 100644
--- a/pkgs/servers/nosql/hyperdex/libmacaroons.nix
+++ b/pkgs/servers/nosql/hyperdex/libmacaroons.nix
@@ -2,11 +2,11 @@
   pkgconfig, libsodium, python }:
 stdenv.mkDerivation rec {
   name = "libmacaroons-${version}";
-  version = "HEAD";
+  version = "0.3.0";
 
   src = fetchurl {
-    url = "https://github.com/rescrv/libmacaroons/archive/6febf3ce6c4c77a46d24b40ed29b03ffbfb175a7.zip";
-    sha256 = "0b4qgim87398chvc3qhxfqv2l1cyl65rhyknln8lk0gq9y00p1ik";
+    url = "https://github.com/rescrv/libmacaroons/archive/releases/${version}.zip";
+    sha256 = "18c44424jri0p5la6jgrnlz5p937hk7ws2mldhzjwisqyf5qld43";
   };
   buildInputs = [ unzip autoconf automake libtool python libsodium pkgconfig ];
   preConfigure = "autoreconf -i";
diff --git a/pkgs/servers/nosql/hyperdex/libpo6.nix b/pkgs/servers/nosql/hyperdex/libpo6.nix
index 166a5e21c6b9..fa68020b539c 100644
--- a/pkgs/servers/nosql/hyperdex/libpo6.nix
+++ b/pkgs/servers/nosql/hyperdex/libpo6.nix
@@ -6,7 +6,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://github.com/rescrv/po6/archive/releases/${version}.zip";
-    sha256 = "14g3ichshnc4wd0iq3q3ymgaq84gjsbqcyn6lri7c7djgkhqijjx";
+    sha256 = "17grzkh6aw1f68qvkhivbb6vwbm6jd41ysbfn88pypf5lczxrxly";
   };
   buildInputs = [ unzip autoconf automake libtool ];
   preConfigure = "autoreconf -i";
diff --git a/pkgs/servers/nosql/hyperdex/replicant.nix b/pkgs/servers/nosql/hyperdex/replicant.nix
index 69146b586723..f2df744e35f1 100644
--- a/pkgs/servers/nosql/hyperdex/replicant.nix
+++ b/pkgs/servers/nosql/hyperdex/replicant.nix
@@ -3,11 +3,11 @@
 
 stdenv.mkDerivation rec {
   name = "replicant-${version}";
-  version = "0.5.2";
+  version = "0.6.3";
 
   src = fetchurl {
-    url = "https://github.com/rescrv/Replicant/archive/releases/0.6.3.zip";
-    sha256 = "1fbagz0nbvinkqr5iw5y187dm4klkswrxnl5ysq8waglg2nj8zzi";
+    url = "https://github.com/rescrv/Replicant/archive/releases/${version}.zip";
+    sha256 = "1q3pdq2ndpj70yd1578bn4grlrp77gl8hv2fz34jpx34qmlalda4";
   };
   buildInputs = [
     autoconf