summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-03-18 11:01:41 +0100
committerVladimír Čunát <vcunat@gmail.com>2018-03-18 11:01:41 +0100
commit214016c11822fdd097b1233f34d4f6df5bfc68d5 (patch)
tree3ff260760ea65a128c104b4aee4b5ed4afd78de5 /pkgs/servers
parent2bbd1d9eb590ec071540d2f58970657ee0ee40fd (diff)
parentadd347c8b20c259a784a88b42bb0b07fdae64782 (diff)
downloadnixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar.gz
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar.bz2
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar.lz
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar.xz
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.tar.zst
nixlib-214016c11822fdd097b1233f34d4f6df5bfc68d5.zip
Merge #37264: archiveopteryx: fix build w/gcc7
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/archiveopteryx/default.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/servers/mail/archiveopteryx/default.nix b/pkgs/servers/mail/archiveopteryx/default.nix
index 50f94e4688c0..080cbc897756 100644
--- a/pkgs/servers/mail/archiveopteryx/default.nix
+++ b/pkgs/servers/mail/archiveopteryx/default.nix
@@ -19,6 +19,13 @@ stdenv.mkDerivation rec {
     sed -i 's:MANDIR = $(PREFIX)/man:MANDIR = '$out'/share/man:' ./Jamsettings
     sed -i 's:READMEDIR = $(PREFIX):READMEDIR = '$out'/share/doc/archiveopteryx:' ./Jamsettings
   '';
+
+  # fix build on gcc7
+  NIX_CFLAGS_COMPILE = [
+    "-Wno-error=builtin-declaration-mismatch"
+    "-Wno-error=implicit-fallthrough"
+  ];
+
   buildPhase = ''jam "-j$NIX_BUILD_CORES" '';
   installPhase = ''
     jam install