summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorAugustin Borsu <a.borsu@gmail.com>2015-11-04 16:04:02 +0000
committerMatej Cotman <cotman.matej@gmail.com>2015-12-02 20:36:40 +0100
commit16fd6c1cf0d9386363c26246c2100c88fd3f2fdf (patch)
treeba390647573b42ea2070cd4449c40d151214df35 /pkgs/servers
parente08ffc472c136c36308f14b67b442f35f6516583 (diff)
downloadnixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar.gz
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar.bz2
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar.lz
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar.xz
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.tar.zst
nixlib-16fd6c1cf0d9386363c26246c2100c88fd3f2fdf.zip
owncloud: 7.0.5 -> 7.0.10 +
Commit changes default version to 7.0.10, 7.0.5 version is kept for
people reluctant to update. Needed info has also been added for
versions 8.0, 8.1 and 8.2 only the latest minor version of each
major version is included.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/owncloud/default.nix71
1 files changed, 51 insertions, 20 deletions
diff --git a/pkgs/servers/owncloud/default.nix b/pkgs/servers/owncloud/default.nix
index 449eee556c1c..4122e940c767 100644
--- a/pkgs/servers/owncloud/default.nix
+++ b/pkgs/servers/owncloud/default.nix
@@ -1,28 +1,59 @@
 { stdenv, fetchurl }:
-stdenv.mkDerivation rec {
-  name= "owncloud-${version}";
-  version = "7.0.5";
+let
+  common = { versiona, sha256 } @ args: stdenv.mkDerivation (rec {
 
-  src = fetchurl {
-    url = "https://download.owncloud.org/community/${name}.tar.bz2";
+    name= "owncloud-${version}";
+    version= versiona;
+
+    src = fetchurl {
+      url = "https://download.owncloud.org/community/${name}.tar.bz2";
+      inherit sha256;
+    };
+
+    installPhase =
+      ''
+        mkdir -p $out
+        find . -maxdepth 1 -execdir cp -r '{}' $out \;
+
+        substituteInPlace $out/lib/base.php \
+          --replace 'OC_Config::$object = new \OC\Config(self::$configDir);' \
+                    'self::$configDir = getenv("OC_CONFIG_PATH"); OC_Config::$object = new \OC\Config(self::$configDir);'
+      '';
+
+    meta = {
+      description = "An enterprise file sharing solution for online collaboration and storage";
+      homepage = https://owncloud.org;
+      maintainers = with stdenv.lib.maintainers; [ matejc ];
+      license = stdenv.lib.licenses.agpl3Plus;
+    };
+
+  });
+
+in {
+
+  owncloud705 = common {
+    versiona = "7.0.5";
     sha256 = "1j21b7ljvbhni9l0b1cpzlhsjy36scyas1l1j222mqdg2srfsi9y";
   };
 
-  installPhase =
-    ''
-      mkdir -p $out
-      find . -maxdepth 1 -execdir cp -r '{}' $out \;
-
-      substituteInPlace $out/lib/base.php \
-        --replace 'OC_Config::$object = new \OC\Config(self::$configDir);' \
-                  'self::$configDir = getenv("OC_CONFIG_PATH"); OC_Config::$object = new \OC\Config(self::$configDir);'
-    '';
-
-  meta = {
-    description = "An enterprise file sharing solution for online collaboration and storage";
-    homepage = https://owncloud.org;
-    maintainers = with stdenv.lib.maintainers; [ matejc ];
-    license = stdenv.lib.licenses.agpl3Plus;
+  owncloud70 = common {
+    versiona = "7.0.10";
+    sha256 = "7e77f27137f37a721a8827b0436a9e71c100406d9745c4251c37c14bcaf31d0b";
+  };
+
+  owncloud80 = common {
+    versiona = "8.0.9";
+    sha256 = "0c1f915f4123dbe07d564cf0172930568690ab5257d2fca4fec4ec515858bef1";
+  };
+
+  owncloud81 = common {
+    versiona = "8.1.4";
+    sha256 = "e0f4bf0c85821fc1b6e7f6268080ad3ca3e98c41baa68a9d616809d74a77312d";
+  };
+
+  owncloud82 = common {
+    versiona = "8.2.0";
+    sha256 = "fcfe99cf1c3aa06ff369e5b1a602147c08dd977af11800fe06c6a661fa5f770c";
   };
 
 }