summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2013-07-04 11:16:02 +0200
committeraszlig <aszlig@redmoonstudios.org>2013-07-08 14:27:43 +0200
commit1182929a0b74720f772e2d8c6d84a7ccf59a881c (patch)
treeaef69505a640640ce9c01f178441dcf9e919ae44 /pkgs/servers
parent1a9e99a8e4e9a0521b081958f03b2347d93178cd (diff)
downloadnixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar.gz
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar.bz2
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar.lz
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar.xz
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.tar.zst
nixlib-1182929a0b74720f772e2d8c6d84a7ccf59a881c.zip
zabbix20: Migrate XMPP support over to minmay.
This should fix support for TLS and in addition, we now _only_ depend on one
library rather than OpenSSL *and* GnuTLS as we no longer need iksemel.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/monitoring/zabbix/2.0.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/pkgs/servers/monitoring/zabbix/2.0.nix b/pkgs/servers/monitoring/zabbix/2.0.nix
index fef5010218cc..90206f358538 100644
--- a/pkgs/servers/monitoring/zabbix/2.0.nix
+++ b/pkgs/servers/monitoring/zabbix/2.0.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl, pkgconfig, postgresql, curl, openssl, zlib, gettext
-, enableJabber ? false, iksemel ? null }:
+, enableJabber ? false, minmay ? null }:
 
-assert enableJabber -> iksemel != null;
+assert enableJabber -> minmay != null;
 
 let
 
@@ -37,7 +37,15 @@ in
       "--with-postgresql"
       "--with-libcurl"
       "--with-gettext"
-    ] ++ stdenv.lib.optional enableJabber "--with-jabber=${iksemel}";
+    ] ++ stdenv.lib.optional enableJabber "--with-jabber=${minmay}";
+
+    postPatch = ''
+      sed -i -e 's/iksemel/minmay/g' configure src/libs/zbxmedia/jabber.c
+      sed -i \
+        -e '/^static ikstransport/,/}/d' \
+        -e 's/iks_connect_with\(.*\), &zbx_iks_transport/mmay_connect_via\1/' \
+        -e 's/iks/mmay/g' -e 's/IKS/MMAY/g' src/libs/zbxmedia/jabber.c
+    '';
 
     buildInputs = [ pkgconfig postgresql curl openssl zlib ];