summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2014-12-25 09:08:10 +0100
committerVladimír Čunát <vcunat@gmail.com>2014-12-25 09:25:05 +0100
commit081e5c8387b957e8d6b6c174321a93a30f323650 (patch)
treeadd41f04be912e7fd37447aa555d7745e82d27b2 /pkgs/servers
parent597373bbd5ca3237f3b198c150cf7dbb63183fb1 (diff)
parent1d131a09a42c47630248a75180882885d33d33b1 (diff)
downloadnixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar.gz
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar.bz2
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar.lz
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar.xz
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.tar.zst
nixlib-081e5c8387b957e8d6b6c174321a93a30f323650.zip
Merge #5061: add xwayland
Also resolve minor nitpicks -- *during* the merge commit.
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/x11/xorg/xwayland.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/servers/x11/xorg/xwayland.nix b/pkgs/servers/x11/xorg/xwayland.nix
new file mode 100644
index 000000000000..f43a9c671604
--- /dev/null
+++ b/pkgs/servers/x11/xorg/xwayland.nix
@@ -0,0 +1,41 @@
+
+{ stdenv, wayland, xorgserver, xkbcomp, xkeyboard_config, epoxy, libxslt, libunwind, makeWrapper }:
+
+with stdenv.lib;
+
+overrideDerivation xorgserver (oldAttrs: {
+
+  name = "xwayland-${xorgserver.version}";
+  propagatedNativeBuildInputs = oldAttrs.propagatedNativeBuildInputs
+    ++ [wayland epoxy libxslt makeWrapper libunwind];
+  configureFlags = [
+    "--disable-docs"
+    "--disable-devel-docs"
+    "--enable-xwayland"
+    "--disable-xorg"
+    "--disable-xvfb"
+    "--disable-xnest"
+    "--disable-xquartz"
+    "--disable-xwin"
+    "--with-default-font-path="
+    "--with-xkb-bin-directory=${xkbcomp}/bin"
+    "--with-xkb-path=${xkeyboard_config}/etc/X11/xkb"
+    "--with-xkb-output=$out/share/X11/xkb/compiled"
+  ];
+
+  postInstall = ''
+    rm -fr $out/share/X11/xkb/compiled
+    ln -s /var/tmp $out/share/X11/xkb/compiled
+  '';
+
+}) // {
+  meta = {
+    description = "An X server for interfacing X11 apps with the Wayland protocol";
+    homepage = http://wayland.freedesktop.org/xserver.html;
+    license = licenses.mit;
+    platforms = platforms.linux;
+  };
+}
+
+
+