summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 12:38:26 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 12:38:26 -0400
commitfd988f8481447a9b6215839d176422b749024077 (patch)
treefb9bf43b05688ef916987f12d960ef895f0c13b9 /pkgs/os-specific
parent3befba542a4264c970de7fde63baa736900c8e53 (diff)
parent81680d44c8733acf8feb69c0c787de5224bf4301 (diff)
downloadnixlib-fd988f8481447a9b6215839d176422b749024077.tar
nixlib-fd988f8481447a9b6215839d176422b749024077.tar.gz
nixlib-fd988f8481447a9b6215839d176422b749024077.tar.bz2
nixlib-fd988f8481447a9b6215839d176422b749024077.tar.lz
nixlib-fd988f8481447a9b6215839d176422b749024077.tar.xz
nixlib-fd988f8481447a9b6215839d176422b749024077.tar.zst
nixlib-fd988f8481447a9b6215839d176422b749024077.zip
Merge another master commit into staging
Again, this is for sake of chained PRs having readable diffs
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel-headers/4.4.nix7
-rw-r--r--pkgs/os-specific/linux/kernel-headers/default.nix29
2 files changed, 1 insertions, 35 deletions
diff --git a/pkgs/os-specific/linux/kernel-headers/4.4.nix b/pkgs/os-specific/linux/kernel-headers/4.4.nix
index 716ad799bc64..0ef5280d13b6 100644
--- a/pkgs/os-specific/linux/kernel-headers/4.4.nix
+++ b/pkgs/os-specific/linux/kernel-headers/4.4.nix
@@ -20,12 +20,7 @@ stdenvNoCC.mkDerivation {
 
   targetConfig = if hostPlatform != buildPlatform then hostPlatform.config else null;
 
-  platform = hostPlatform.platform.kernelArch or (
-    if hostPlatform.system == "i686-linux" then "i386" else
-    if hostPlatform.system == "x86_64-linux" then "x86_64" else
-    if hostPlatform.system == "powerpc-linux" then "powerpc" else
-    if hostPlatform.isArm then "arm" else
-    abort "don't know what the kernel include directory is called for this platform");
+  platform = hostPlatform.platform.kernelArch;
 
   # It may look odd that we use `stdenvNoCC`, and yet explicit depend on a cc.
   # We do this so we have a build->build, not build->host, C compiler.
diff --git a/pkgs/os-specific/linux/kernel-headers/default.nix b/pkgs/os-specific/linux/kernel-headers/default.nix
deleted file mode 100644
index da67747b8b24..000000000000
--- a/pkgs/os-specific/linux/kernel-headers/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ stdenv, kernel, perl
-, hostPlatform
-}:
-
-let
-  baseBuildFlags = [ "INSTALL_HDR_PATH=$(out)" "headers_install" ];
-in stdenv.mkDerivation {
-  name = "linux-headers-${kernel.version}";
-
-  inherit (kernel) src patches;
-
-  nativeBuildInputs = [ perl ];
-
-  buildFlags = [ "ARCH=${stdenv.platform.kernelArch}" ] ++ baseBuildFlags;
-
-  crossAttrs = {
-    inherit (kernel.crossDrv) src patches;
-    buildFlags = [ "ARCH=${hostPlatform.platform.kernelArch}" ] ++ baseBuildFlags;
-  };
-
-  installPhase = ''
-    find $out \( -name ..install.cmd -o -name .install \) -print0 | xargs -0 rm
-  '';
-
-  # Headers shouldn't reference anything else
-  allowedReferences = [];
-
-  meta.platforms = stdenv.lib.platforms.linux;
-}