summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorTim Steinbach <tim@nequissimus.com>2018-04-17 20:28:11 -0400
committerTim Steinbach <tim@nequissimus.com>2018-04-17 20:28:11 -0400
commitf8665f18fb066d1cc59e729d64e1b9976080d030 (patch)
tree87f60d94e7d0894fa8a28627056de5d5e6c5ba57 /pkgs/os-specific
parent329ca7db6cfd1d9529873c9a66f6f44be5af22bc (diff)
downloadnixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar.gz
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar.bz2
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar.lz
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar.xz
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.tar.zst
nixlib-f8665f18fb066d1cc59e729d64e1b9976080d030.zip
linux: 4.16-rc7 -> 4.17-rc1
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/common-config.nix8
-rw-r--r--pkgs/os-specific/linux/kernel/linux-testing.nix8
2 files changed, 10 insertions, 6 deletions
diff --git a/pkgs/os-specific/linux/kernel/common-config.nix b/pkgs/os-specific/linux/kernel/common-config.nix
index f8c4b95bb618..4d9ec389f44e 100644
--- a/pkgs/os-specific/linux/kernel/common-config.nix
+++ b/pkgs/os-specific/linux/kernel/common-config.nix
@@ -115,7 +115,6 @@ with stdenv.lib;
   # Enable various subsystems.
   ACCESSIBILITY y # Accessibility support
   AUXDISPLAY y # Auxiliary Display support
-  DONGLE y # Serial dongle support
   HIPPI y
   MTD_COMPLEX_MAPPINGS y # needed for many devices
   SCSI_LOWLEVEL y # enable lots of SCSI devices
@@ -124,6 +123,9 @@ with stdenv.lib;
   SPI y # needed for many devices
   SPI_MASTER y
   WAN y
+  ${optionalString (versionOlder version "4.17") ''
+    DONGLE y # Serial dongle support
+  ''}
 
   # Networking options.
   NET y
@@ -420,7 +422,9 @@ with stdenv.lib;
   ${optionalString (versionAtLeast version "4.3") ''
     IDLE_PAGE_TRACKING y
   ''}
-  IRDA_ULTRA y # Ultra (connectionless) protocol
+  ${optionalString (versionOlder version "4.17") ''
+    IRDA_ULTRA y # Ultra (connectionless) protocol
+  ''}
   JOYSTICK_IFORCE_232? y # I-Force Serial joysticks and wheels
   JOYSTICK_IFORCE_USB? y # I-Force USB joysticks and wheels
   JOYSTICK_XPAD_FF? y # X-Box gamepad rumble support
diff --git a/pkgs/os-specific/linux/kernel/linux-testing.nix b/pkgs/os-specific/linux/kernel/linux-testing.nix
index 5e8e861af258..6c0f01fb8ad7 100644
--- a/pkgs/os-specific/linux/kernel/linux-testing.nix
+++ b/pkgs/os-specific/linux/kernel/linux-testing.nix
@@ -1,13 +1,13 @@
 { stdenv, buildPackages, hostPlatform, fetchurl, perl, buildLinux, libelf, utillinux, ... } @ args:
 
 buildLinux (args // rec {
-  version = "4.16-rc7";
-  modDirVersion = "4.16.0-rc7";
-  extraMeta.branch = "4.16";
+  version = "4.17-rc1";
+  modDirVersion = "4.17.0-rc1";
+  extraMeta.branch = "4.17";
 
   src = fetchurl {
     url = "https://git.kernel.org/torvalds/t/linux-${version}.tar.gz";
-    sha256 = "13zpfjxd38202afjl6flc9brjw3sp4sfq3wls0v90k1i2b308qfi";
+    sha256 = "0a3lrax6f8f98lj65aawpqkzkmxcl2x4h20kr0cr7wf0jvpnn5y3";
   };
 
   # Should the testing kernels ever be built on Hydra?