summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2010-08-11 10:43:09 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2010-08-11 10:43:09 +0000
commite4686546ecc4175712a50e6da4b659a8b86949ef (patch)
treede90c68e5dd4f7a885741f972f356461d1bd0626 /pkgs/os-specific
parentcf1d2fb7542abfbe6ce42e1639db99b7d9ef0405 (diff)
downloadnixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar.gz
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar.bz2
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar.lz
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar.xz
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.tar.zst
nixlib-e4686546ecc4175712a50e6da4b659a8b86949ef.zip
* Enable parallel building for the Linux kernel, an obvious candidate.
svn path=/nixpkgs/trunk/; revision=23109
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/generic.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/kernel/generic.nix b/pkgs/os-specific/linux/kernel/generic.nix
index 158117133244..408603841220 100644
--- a/pkgs/os-specific/linux/kernel/generic.nix
+++ b/pkgs/os-specific/linux/kernel/generic.nix
@@ -60,6 +60,8 @@ in
 stdenv.mkDerivation {
   name = if userModeLinux then "user-mode-linux-${version}" else "linux-${version}";
 
+  enableParallelBuilding = true;
+
   passthru = {
     inherit version;
     # Combine the `features' attribute sets of all the kernel patches.