summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-04-19 15:22:26 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-04-19 15:23:36 +0200
commite3ac73af1149ff92e4e9ed9de80a65b673bdb9c2 (patch)
tree65c0c8b42e819274b7482035fef2c2b71e75d753 /pkgs/os-specific
parentfc206609451ca5888b1f6e54c7a6c7e83270a26d (diff)
downloadnixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar.gz
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar.bz2
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar.lz
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar.xz
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.tar.zst
nixlib-e3ac73af1149ff92e4e9ed9de80a65b673bdb9c2.zip
systemd.libudev: don't depend on the main output
Also fix some references, and drop unused makeFlags:
https://github.com/NixOS/nixpkgs/commit/3300479c#commitcomment-10790021
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/systemd/default.nix17
1 files changed, 9 insertions, 8 deletions
diff --git a/pkgs/os-specific/linux/systemd/default.nix b/pkgs/os-specific/linux/systemd/default.nix
index c10d53c5c75e..d193270e8ea2 100644
--- a/pkgs/os-specific/linux/systemd/default.nix
+++ b/pkgs/os-specific/linux/systemd/default.nix
@@ -90,9 +90,17 @@ stdenv.mkDerivation rec {
       export NIX_CFLAGS_LINK+=" -Wl,-rpath,$libudev/lib"
     '';
 
+  makeFlags = [
+    "udevlibexecdir=$(libudev)/lib"
+    # udev rules refer to $out, and anything but libs should probably go to $out
+    "udevrulesdir=$(out)/lib"
+    "udevhomedir=$(out)/lib"
+    "udevhwdbdir=$(out)/lib"
+  ];
+
   # This is needed because systemd uses the gold linker, which doesn't
   # yet have the wrapper script to add rpath flags automatically.
-  NIX_LDFLAGS = "-rpath ${pam}/lib -rpath ${libcap}/lib -rpath ${acl}/lib -rpath ${stdenv.cc.cc}/lib";
+  NIX_LDFLAGS = "-rpath ${pam.out}/lib -rpath ${libcap.out}/lib -rpath ${acl.out}/lib -rpath ${stdenv.cc.cc}/lib";
 
   PYTHON_BINARY = "${coreutils}/bin/env python"; # don't want a build time dependency on Python
 
@@ -110,13 +118,6 @@ stdenv.mkDerivation rec {
       "-USYSTEMD_BINARY_PATH" "-DSYSTEMD_BINARY_PATH=\"/run/current-system/systemd/lib/systemd/systemd\""
     ];
 
-  # Use /var/lib/udev rather than /etc/udev for the generated hardware
-  # database.  Upstream doesn't want this (see commit
-  # 1e1954f53386cb773e2a152748dd31c4d36aa2d8) because using /var is
-  # forbidden in early boot, but in NixOS the initrd guarantees that
-  # /var is mounted.
-  makeFlags = "hwdb_bin=/var/lib/udev/hwdb.bin";
-
   enableParallelBuilding = true;
 
   installFlags =