summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMarco Maggesi <maggesi@math.unifi.it>2009-11-08 10:38:07 +0000
committerMarco Maggesi <maggesi@math.unifi.it>2009-11-08 10:38:07 +0000
commite3204aa4073479ba659872b3e96c762e1f5e2bc1 (patch)
tree7ad381f493a5ea263ce873921c1775ddd54feeef /pkgs/os-specific
parentedf78fcb6a144444cdea9897f87d486252a1e090 (diff)
downloadnixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar.gz
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar.bz2
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar.lz
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar.xz
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.tar.zst
nixlib-e3204aa4073479ba659872b3e96c762e1f5e2bc1.zip
New version of cryopid.
Update package cryopid to a new (unstable) version.
The old (stable) version of cryopid works only with old linux kernels.

svn path=/nixpkgs/trunk/; revision=18286
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/cryopid/default.nix37
1 files changed, 13 insertions, 24 deletions
diff --git a/pkgs/os-specific/linux/cryopid/default.nix b/pkgs/os-specific/linux/cryopid/default.nix
index a5f6f4fa5b20..0cb64bcc9753 100644
--- a/pkgs/os-specific/linux/cryopid/default.nix
+++ b/pkgs/os-specific/linux/cryopid/default.nix
@@ -2,36 +2,25 @@
 
 let
 
-  src32 = fetchurl {
-    url = http://dagobah.ucc.asn.au/wacky/cryopid-0.5.9.1-i386.tar.gz;
-    sha256 = "14175pc87x932c09cl1n5iwc5v1086gd4xpb4pz7d5fvqpaxca3h";
-  };
+  pname = "cryopid";
+  version = "20090908";
+  revision = "7da69201d50e";
 
-  src64 = fetchurl {
-    url = http://dagobah.ucc.asn.au/wacky/cryopid-0.5.9.1-x86_64.tar.gz;
-    sha256 = "0y3h9fvb59c8i07das5srhprnsbj1i9m93fp37mzqcjxi2gwjw3b";
-  };
-  
 in
 
-stdenv.mkDerivation {
-  name = "cryopid-0.5.9.1";
+stdenv.mkDerivation rec {
+  name = "${pname}-${version}";
 
-  src =
-    if stdenv.system == "i686-linux" then src32
-    else if stdenv.system == "x86_64-linux" then src64
-    else throw "unsupported platform for CryoPID";
+  src = fetchurl {
+    url = "https://sharesource.org/hg/cryopid/archive/${revision}.tar.bz2";
+    sha256 = "908a4b1cb26322ee25afe13ff59e0d86f669538cb4583766b15ca79fda6c69ca";
+  };
 
-  buildInputs = [zlibStatic];
+  buildInputs = [ zlibStatic ];
 
-  buildPhase = ''
-    make -C src ARCH=i386
-  '';
+  preBuild = "cd src";
 
-  installPhase = ''
-    mkdir -p $out/bin
-    cp src/freeze $out/bin
-  '';
+  installPhase = "mkdir -p $out/bin; cp cryopid $out/bin";
 
   meta = {
     description = "A process freezer for Linux";
@@ -40,7 +29,7 @@ stdenv.mkDerivation {
       and save it to a file.  This file can then be used to resume the process
       later on, either after a reboot or even on another machines.
     '';
-    homepage = http://cryopid.berlios.de;
+    homepage = http://sharesource.org/project/cryopid;
     license = ''
       Modified BSD license (without advertising clause).  CryoPID ships with
       and links against the dietlibc library, which is distributed under the