summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2011-07-23 22:58:32 +0000
committerShea Levy <shea@shealevy.com>2011-07-23 22:58:32 +0000
commitd9c22f38da94f187b8a59051fc01fb28df739aa0 (patch)
tree23b54b5a44939c7e8ec18f7cc1e331b44a344897 /pkgs/os-specific
parent14be409d8fb300a75cf78477682a85a7a9f2edfb (diff)
downloadnixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar.gz
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar.bz2
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar.lz
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar.xz
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.tar.zst
nixlib-d9c22f38da94f187b8a59051fc01fb28df739aa0.zip
Add firmware for rtl8192c and related NICs
svn path=/nixpkgs/trunk/; revision=27912
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/rtl8192c/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/firmware/rtl8192c/default.nix b/pkgs/os-specific/linux/firmware/rtl8192c/default.nix
new file mode 100644
index 000000000000..0ab7436ebfff
--- /dev/null
+++ b/pkgs/os-specific/linux/firmware/rtl8192c/default.nix
@@ -0,0 +1,23 @@
+{stdenv, fetchurl}:
+
+stdenv.mkDerivation rec {
+  name = "rtl8192c-fw";
+  src = fetchurl {
+    url = "ftp://WebUser:n8W9ErCy@208.70.202.219/cn/wlan/92ce_se_de_linux_mac80211_0003.0401.2011.tar.gz";
+    sha256 = "002kj6f1xaali2iwrxvirqq0hbiyb2cpf93y2xycp3qd69cp8lik";
+  };
+
+  phases = [ "unpackPhase" "installPhase" ];
+
+  # Installation copies the firmware AND the license.  The license
+  # says: "Your rights to redistribute the Software shall be
+  # contingent upon your installation of this Agreement in its
+  # entirety in the same directory as the Software."
+  installPhase = "ensureDir $out; cp -a firmware/* $out";
+  
+  meta = {
+    description = "Firmware for the Realtek RTL8192c wireless cards";
+    homepage = "http://www.realtek.com";
+    license = "non-free";
+  };
+}