summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2018-07-24 18:30:14 -0400
committerGitHub <noreply@github.com>2018-07-24 18:30:14 -0400
commitd4f5ee8199cedb03b1a81379e2019a29484d3625 (patch)
tree98122862b06334c2f3b1ebaa35afee839f129b0f /pkgs/os-specific
parent4295da8af4bf330c79031645ca650caf3cc5b625 (diff)
parent1f9838ea344198e2119ed791ea52acedf1f3c6d9 (diff)
downloadnixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar.gz
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar.bz2
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar.lz
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar.xz
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.tar.zst
nixlib-d4f5ee8199cedb03b1a81379e2019a29484d3625.zip
Merge pull request #44065 from Ericson2314/no-crossAttrs-master
treewide: Remove some crossAttrs
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/gnu/hurd/default.nix3
-rw-r--r--pkgs/os-specific/gnu/mig/default.nix12
-rw-r--r--pkgs/os-specific/windows/jom/default.nix12
3 files changed, 12 insertions, 15 deletions
diff --git a/pkgs/os-specific/gnu/hurd/default.nix b/pkgs/os-specific/gnu/hurd/default.nix
index ae1c504fd19e..a0c4be0ff451 100644
--- a/pkgs/os-specific/gnu/hurd/default.nix
+++ b/pkgs/os-specific/gnu/hurd/default.nix
@@ -52,7 +52,8 @@ stdenv.mkDerivation ({
        done
     '';
 
-  crossAttrs.dontPatchShebangs = true;
+  # Not needed after https://github.com/NixOS/nixpkgs/pull/43833
+  dontPatchShebangs = stdenv.hostPlatform != stdenv.buildPlatform;
 
   meta = {
     description = "The GNU Hurd, GNU project's replacement for the Unix kernel";
diff --git a/pkgs/os-specific/gnu/mig/default.nix b/pkgs/os-specific/gnu/mig/default.nix
index 2855f5b4240f..d138011d595b 100644
--- a/pkgs/os-specific/gnu/mig/default.nix
+++ b/pkgs/os-specific/gnu/mig/default.nix
@@ -21,13 +21,11 @@ stdenv.mkDerivation {
 
   doCheck = true;
 
-  crossAttrs = {
-    postInstall =
-      # Fix the shebang to point to the cross-built shell.
-      '' sed -i "$out/bin/mig" \
-             -e 's|^#!/.*|#!${bash.crossDrv}/bin/sh|g'
-      '';
-  };
+  # Fix the shebang to point to the cross-built shell. Won't be needed
+  # after #43833.
+  postInstall = ''
+    sed -i "$out/bin/mig" -e 's|^#!/.*|#!${bash}/bin/sh|g'
+  '';
 
   meta = {
     description = "GNU MIG, the Mach interface generator";
diff --git a/pkgs/os-specific/windows/jom/default.nix b/pkgs/os-specific/windows/jom/default.nix
index 8befa51566de..1b64ad745991 100644
--- a/pkgs/os-specific/windows/jom/default.nix
+++ b/pkgs/os-specific/windows/jom/default.nix
@@ -17,13 +17,11 @@ stdenv.mkDerivation {
 
   QTDIR = qt48;
   
-  crossAttrs = {
-    # cmakeFlags = "-DWIN32=1 -DCMAKE_SYSTEM_NAME=Windows -DCMAKE_RC_COMPILER=${stdenv.cc.targetPrefix}windres";
-    QTDIR = qt48.crossDrv;
-    preBuild = ''
-      export NIX_CROSS_CFLAGS_COMPILE=-fpermissive
-    '';
-  };
+  # cmakeFlags = "-DWIN32=1 -DCMAKE_SYSTEM_NAME=Windows -DCMAKE_RC_COMPILER=${stdenv.cc.targetPrefix}windres";
+
+  preBuild = stdenv.lib.optionalString (stdenv.hostPlatform != stdenv.buildPlatform) ''
+    export NIX_CROSS_CFLAGS_COMPILE=-fpermissive
+  '';
 
   meta = {
     homepage = http://qt-project.org/wiki/jom;