summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2016-08-13 16:59:55 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2016-08-13 16:59:55 +0200
commitbd4490e2772ff80149dc9236873cfcbf1cb3f846 (patch)
treee08b232c3e346efaff4a549b855fae1feb919b47 /pkgs/os-specific
parentfa3a35b241def2f837d72b5de736c513d6856cf9 (diff)
parent79149ac12d5009169900f027de2633a843e614f0 (diff)
downloadnixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar.gz
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar.bz2
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar.lz
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar.xz
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.tar.zst
nixlib-bd4490e2772ff80149dc9236873cfcbf1cb3f846.zip
Merge branch 'master' into hardened-stdenv
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/linux-mptcp.nix10
-rw-r--r--pkgs/os-specific/linux/kernel/patches.nix4
-rw-r--r--pkgs/os-specific/linux/kernel/qat_common_Makefile.patch10
-rw-r--r--pkgs/os-specific/linux/microcode/intel.nix6
4 files changed, 9 insertions, 21 deletions
diff --git a/pkgs/os-specific/linux/kernel/linux-mptcp.nix b/pkgs/os-specific/linux/kernel/linux-mptcp.nix
index 981e6a97c2a0..b39514d45dd9 100644
--- a/pkgs/os-specific/linux/kernel/linux-mptcp.nix
+++ b/pkgs/os-specific/linux/kernel/linux-mptcp.nix
@@ -1,20 +1,22 @@
 { stdenv, fetchurl, perl, buildLinux, ... } @ args:
 
 import ./generic.nix (args // rec {
-  mptcpVersion = "0.90.1";
-  modDirVersion = "3.18.25";
+  mptcpVersion = "0.91";
+  modDirVersion = "4.1.26";
   version = "${modDirVersion}-mptcp_v${mptcpVersion}";
 
   extraMeta = {
-    branch = "3.18";
+    branch = "4.1";
     maintainers = stdenv.lib.maintainers.layus;
   };
 
   src = fetchurl {
     url = "https://github.com/multipath-tcp/mptcp/archive/v${mptcpVersion}.tar.gz";
-    sha256 = "088cpxl960xzrsz7x2lkq28ksa4gzjb1hp5yf8hxshihyhdaspwl";
+    sha256 = "0rbvgz89j5wk781y201qdxy2kz4gmlamb72wdbxj8mxv92x56lh3";
   };
 
+  kernelPatches = args.kernelPatches;
+
   extraConfig = ''
     IPV6 y
     MPTCP y
diff --git a/pkgs/os-specific/linux/kernel/patches.nix b/pkgs/os-specific/linux/kernel/patches.nix
index 56963d89efaa..f0aa4c92b3c5 100644
--- a/pkgs/os-specific/linux/kernel/patches.nix
+++ b/pkgs/os-specific/linux/kernel/patches.nix
@@ -136,10 +136,6 @@ rec {
     { name = "mfd_fix_dependency";
       patch = ./chromiumos-patches/mfd-fix-dependency.patch;
     };
-  qat_common_Makefile =
-    { name = "qat_common_Makefile";
-      patch = ./qat_common_Makefile.patch;
-    };
 
   hiddev_CVE_2016_5829 =
     { name = "hiddev_CVE_2016_5829";
diff --git a/pkgs/os-specific/linux/kernel/qat_common_Makefile.patch b/pkgs/os-specific/linux/kernel/qat_common_Makefile.patch
deleted file mode 100644
index 2d4476a7fe50..000000000000
--- a/pkgs/os-specific/linux/kernel/qat_common_Makefile.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/drivers/crypto/qat/qat_common/Makefile
-+++ b/drivers/crypto/qat/qat_common/Makefile
-@@ -2,6 +2,7 @@
- 			     $(obj)/qat_rsapubkey-asn1.h
- $(obj)/qat_rsaprivkey-asn1.o: $(obj)/qat_rsaprivkey-asn1.c \
- 			      $(obj)/qat_rsaprivkey-asn1.h
-+$(obj)/qat_asym_algs.o: $(obj)/qat_rsaprivkey-asn1.h $(obj)/qat_rsapubkey-asn1.h
- 
- clean-files += qat_rsapubkey-asn1.c qat_rsapubkey-asn1.h
- clean-files += qat_rsaprivkey-asn1.c qat_rsapvivkey-asn1.h
diff --git a/pkgs/os-specific/linux/microcode/intel.nix b/pkgs/os-specific/linux/microcode/intel.nix
index ea9ff1d58d1a..6fa947fea17a 100644
--- a/pkgs/os-specific/linux/microcode/intel.nix
+++ b/pkgs/os-specific/linux/microcode/intel.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "microcode-intel-${version}";
-  version = "20150121";
+  version = "20160714";
 
   src = fetchurl {
-    url = "http://downloadmirror.intel.com/24661/eng/microcode-${version}.tgz";
-    sha256 = "1cznv3f25cxkwxdc930ab0ifvq0c76fryppadi4p26a2pf9knd93";
+    url = "http://downloadmirror.intel.com/26156/eng/microcode-${version}.tgz";
+    sha256 = "03l4pkymrgbd5y9m5ys7kq85zvckmjbw7xr6pkzg2nr7jgycdagk";
   };
 
   buildInputs = [ libarchive ];