summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-01-06 17:04:32 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2012-01-06 17:04:32 +0000
commitb76352800ec85580936cb07a9c27a6fc3e105cfa (patch)
treeffede1950503c724e36ccd96ff5d03838064e074 /pkgs/os-specific
parentcae619da08cd663f05d905cbbd3b47f7d56aaa0b (diff)
downloadnixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar.gz
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar.bz2
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar.lz
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar.xz
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.tar.zst
nixlib-b76352800ec85580936cb07a9c27a6fc3e105cfa.zip
Adding slang to perf. It looks like it wants slang too.
svn path=/nixpkgs/trunk/; revision=31354
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/perf.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/kernel/perf.nix b/pkgs/os-specific/linux/kernel/perf.nix
index e45a15150d78..40b7638b911f 100644
--- a/pkgs/os-specific/linux/kernel/perf.nix
+++ b/pkgs/os-specific/linux/kernel/perf.nix
@@ -1,4 +1,4 @@
-{ stdenv, kernel, elfutils, python, perl, newt }:
+{ stdenv, kernel, elfutils, python, perl, newt, slang }:
 
 stdenv.mkDerivation {
   name = "perf-linux-${kernel.version}";
@@ -11,7 +11,8 @@ stdenv.mkDerivation {
     export makeFlags="DESTDIR=$out $makeFlags"
   '';
 
-  buildInputs = [ elfutils python perl newt ];
+  # perf refers both to newt and slang
+  buildInputs = [ elfutils python perl newt slang ];
 
   inherit elfutils;