summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorAnders Papitto <anderspapitto@gmail.com>2016-10-05 17:59:44 -0700
committerAnders Papitto <anderspapitto@gmail.com>2016-10-05 17:59:44 -0700
commitaa44330963a9e407c5728d7521fb3cb56411d506 (patch)
tree3f95870d9921baee105b555edf0ddd8bb47c8206 /pkgs/os-specific
parentadfcc2d9531e78bf6a9e3b56e2f4fc873cb3d87b (diff)
downloadnixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar.gz
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar.bz2
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar.lz
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar.xz
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.tar.zst
nixlib-aa44330963a9e407c5728d7521fb3cb56411d506.zip
perf: add dependency on libaudit
the `trace` subcommand of perf is only enabled when libaudit is
available at compile time
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/perf.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/kernel/perf.nix b/pkgs/os-specific/linux/kernel/perf.nix
index 69a951875a53..9e5724984576 100644
--- a/pkgs/os-specific/linux/kernel/perf.nix
+++ b/pkgs/os-specific/linux/kernel/perf.nix
@@ -1,6 +1,6 @@
 { lib, stdenv, kernel, elfutils, python, perl, newt, slang, asciidoc, xmlto
 , docbook_xsl, docbook_xml_dtd_45, libxslt, flex, bison, pkgconfig, libunwind, binutils
-, libiberty
+, libiberty, libaudit
 , zlib, withGtk ? false, gtk2 ? null }:
 
 with lib;
@@ -24,7 +24,7 @@ stdenv.mkDerivation {
   # perf refers both to newt and slang
   # binutils is required for libbfd.
   nativeBuildInputs = [ asciidoc xmlto docbook_xsl docbook_xml_dtd_45 libxslt
-      flex bison libiberty ];
+      flex bison libiberty libaudit ];
   buildInputs = [ elfutils python perl newt slang pkgconfig libunwind binutils zlib ] ++
     stdenv.lib.optional withGtk gtk2;