summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 13:01:12 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-09-15 13:01:12 -0400
commita31365d831c5b73e2414d7e14c8612ef7972466e (patch)
tree58ff7350f7c8c78a56c985a02ef386fd5e5919f9 /pkgs/os-specific
parentfd988f8481447a9b6215839d176422b749024077 (diff)
downloadnixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar.gz
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar.bz2
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar.lz
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar.xz
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.tar.zst
nixlib-a31365d831c5b73e2414d7e14c8612ef7972466e.zip
Revert "Merge commit on master into staging"
This was reverted on master in
3510197dccd999ac7189e70d819e0c6a61296817, and so needs to be reverted
here too.

This reverts commit 3befba542a4264c970de7fde63baa736900c8e53, reversing
changes made to 3655e7e18bf7c2b7eeadf824d8c4230a487ca16e.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/ghc-standalone-archive/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
index 227a8c59985c..d23328d362e0 100644
--- a/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
+++ b/pkgs/os-specific/darwin/ghc-standalone-archive/default.nix
@@ -2,7 +2,8 @@
 { haskellPackages, src, deps ? p : [], name }: let
   inherit (haskellPackages) ghc ghcWithPackages;
   with-env = ghcWithPackages deps;
-  ghcName = "${ghc.prefix}ghc";
+  crossPrefix = if (ghc.cross or null) != null then "${ghc.cross.config}-" else "";
+  ghcName = "${crossPrefix}ghc";
 in runCommand name { buildInputs = [ with-env cctools ]; } ''
   mkdir -p $out/lib
   mkdir -p $out/include