summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-03-12 21:30:57 +0000
committerGitHub <noreply@github.com>2018-03-12 21:30:57 +0000
commit9715e278c118633d503caf12e33a04ef3cc55dfe (patch)
treecf10700fa6d7ea6432d7009babc28d518db26e70 /pkgs/os-specific
parentb0fa004fa9247a15c31f4f986791c025f9242c3d (diff)
parent11d40d53314a3f3d100ace991484543a5769887e (diff)
downloadnixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar.gz
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar.bz2
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar.lz
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar.xz
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.tar.zst
nixlib-9715e278c118633d503caf12e33a04ef3cc55dfe.zip
Merge pull request #36879 from markuskowa/beegfs-6.18
beegfs: 6.17 -> 6.18
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/beegfs/default.nix4
-rw-r--r--pkgs/os-specific/linux/beegfs/kernel-module.nix5
2 files changed, 4 insertions, 5 deletions
diff --git a/pkgs/os-specific/linux/beegfs/default.nix b/pkgs/os-specific/linux/beegfs/default.nix
index 6cf233694cdc..f17bc9492c1b 100644
--- a/pkgs/os-specific/linux/beegfs/default.nix
+++ b/pkgs/os-specific/linux/beegfs/default.nix
@@ -5,7 +5,7 @@
 } :
 
 let
-  version = "6.17";
+  version = "6.18";
 
   subdirs = [
     "beeond_thirdparty/build"
@@ -30,7 +30,7 @@ in stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "https://git.beegfs.com/pub/v6/repository/archive.tar.bz2?ref=${version}";
-    sha256 = "10xs7gzdmlg23k6zn1b7jij3lljn7rr1j6h476hq4lbg981qk3n3";
+    sha256 = "1g874qyxh4v53ah3lzchrqi0jci7wngr54q3f4d9q0kzvvifripn";
   };
 
   nativeBuildInputs = [ which unzip pkgconfig cppunit openjdk ant perl ];
diff --git a/pkgs/os-specific/linux/beegfs/kernel-module.nix b/pkgs/os-specific/linux/beegfs/kernel-module.nix
index 4525d156159b..63e45928f217 100644
--- a/pkgs/os-specific/linux/beegfs/kernel-module.nix
+++ b/pkgs/os-specific/linux/beegfs/kernel-module.nix
@@ -3,13 +3,13 @@
 } :
 
 let
-  version = "6.17";
+  version = "6.18";
 in stdenv.mkDerivation {
   name = "beegfs-module-${version}-${kernel.version}";
 
   src = fetchurl {
     url = "https://git.beegfs.com/pub/v6/repository/archive.tar.bz2?ref=${version}";
-    sha256 = "10xs7gzdmlg23k6zn1b7jij3lljn7rr1j6h476hq4lbg981qk3n3";
+    sha256 = "1g874qyxh4v53ah3lzchrqi0jci7wngr54q3f4d9q0kzvvifripn";
   };
 
   hardeningDisable = [ "fortify" "pic" "stackprotector" ];
@@ -41,6 +41,5 @@ in stdenv.mkDerivation {
     platforms = [ "i686-linux" "x86_64-linux" ];
     license = licenses.gpl2;
     maintainers = with maintainers; [ markuskowa ];
-    broken = versionAtLeast kernel.version "4.14";
   };
 }