summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-07-09 17:30:08 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-07-09 17:30:08 +0000
commit89b116ba674cc5cbb72e2c07dd00cbe72f0901b1 (patch)
tree0d14cd870b83f696566a2eac9371fb7fa6c6bff6 /pkgs/os-specific
parentb6a84f5c50a37e29cde701292744fa57c8f822bd (diff)
downloadnixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar.gz
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar.bz2
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar.lz
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar.xz
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.tar.zst
nixlib-89b116ba674cc5cbb72e2c07dd00cbe72f0901b1.zip
Adding firmware for the wireless cards rt2870 (for a rt3072 hw in fact)
svn path=/nixpkgs/trunk/; revision=22551
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/rt2870/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/firmware/rt2870/default.nix b/pkgs/os-specific/linux/firmware/rt2870/default.nix
new file mode 100644
index 000000000000..6d28ba2ba858
--- /dev/null
+++ b/pkgs/os-specific/linux/firmware/rt2870/default.nix
@@ -0,0 +1,26 @@
+{stdenv, fetchurl, unzip}:
+
+stdenv.mkDerivation {
+  name = "rt2870-fw-22";
+  src = fetchurl {
+    url = "http://www.ralinktech.com/download.php?t=U0wyRnpjMlYwY3k4eU1ERXdMekF6THpNeEwyUnZkMjVzYjJGa01UWXpPRGs1T0Rnek5pNTZhWEE5UFQxU1ZESTROekJmUm1seWJYZGhjbVZmVmpJeUM%3D";
+    name = "RT2870_Firmware_V22.zip";
+    sha256 = "d24591a8529b0a609cc3c626ecee96484bb29b2c020260b82f6025459c11f263";
+  };
+
+  buildInputs = [ unzip ];
+  
+  buildPhase = "true";
+
+  # Installation copies the firmware AND the license.  The license
+  # says: "Your rights to redistribute the Software shall be
+  # contingent upon your installation of this Agreement in its
+  # entirety in the same directory as the Software."
+  installPhase = "ensureDir $out; cp * $out";
+  
+  meta = {
+    description = "Firmware for the Ralink RT2870 wireless cards";
+    homepage = http://www.ralinktech.com/;
+    license = "non-free";
+  };
+}