summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorqoli <qoli@protonmail.com>2018-06-18 16:47:16 -0700
committerqoli <qoli@protonmail.com>2018-06-18 20:48:11 -0700
commit8100691b3e5d24618f691c6aef25d6685f273556 (patch)
treedfff43b8f0a141d9de3fef5c833badfe2a712f0b /pkgs/os-specific
parent1f8f89d309eeebfe00b25c30cc9dca103f3d8b47 (diff)
downloadnixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar.gz
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar.bz2
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar.lz
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar.xz
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.tar.zst
nixlib-8100691b3e5d24618f691c6aef25d6685f273556.zip
Cryptsetup: 2.0.2 -> 2.0.3. Also, add upstream libressl-2.7 patch.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/cryptsetup/default.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/cryptsetup/default.nix b/pkgs/os-specific/linux/cryptsetup/default.nix
index 4a64154b585d..e1da0a449c5b 100644
--- a/pkgs/os-specific/linux/cryptsetup/default.nix
+++ b/pkgs/os-specific/linux/cryptsetup/default.nix
@@ -1,16 +1,24 @@
-{ stdenv, fetchurl, devicemapper, json_c, openssl, libuuid, pkgconfig, popt
+{ stdenv, fetchurl, fetchpatch, devicemapper, json_c, openssl, libuuid, pkgconfig, popt
 , enablePython ? false, python2 ? null }:
 
 assert enablePython -> python2 != null;
 
 stdenv.mkDerivation rec {
-  name = "cryptsetup-2.0.2";
+  name = "cryptsetup-2.0.3";
 
   src = fetchurl {
     url = "mirror://kernel/linux/utils/cryptsetup/v2.0/${name}.tar.xz";
-    sha256 = "15wyjfgcqjf0wy5gxnmjj8aah33csv5v6n1hv9c8sxdzygbhb0ag";
+    sha256 = "1m01wl8njjraz69fsk97l3nqfc32nbpr1la5s1l4mzzmq42clv2d";
   };
 
+  patches = [
+    # NOTE: Patch to support LibreSSL-2.7. It is from upstream, and can be removed when cryptsetup is next updated.
+    (fetchpatch {
+      url = "https://gitlab.com/cryptsetup/cryptsetup/commit/5fcf430c8105fbeeb07a8cacbae84f941d2a3d55.patch";
+      sha256 = "1d3ycsqszq0frlv9r7kmfdfmnk4qa4b4mv25iivmayvpgc8yja7m";
+    })
+  ];
+
   NIX_LDFLAGS = "-lgcc_s";
 
   configureFlags = [