summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <git@JohnEricson.me>2018-10-24 10:35:52 -0400
committerGitHub <noreply@github.com>2018-10-24 10:35:52 -0400
commit7d96d1502015877d12a816658f0bf3bfc7540129 (patch)
treee982d6ea4c29a6abe026422cea5248ffdb101038 /pkgs/os-specific
parent6615b769961a1ff4413f0d9c64d325216184dec7 (diff)
parentbbd12f558367034c77c68795c88b01b9cf5705dd (diff)
downloadnixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar.gz
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar.bz2
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar.lz
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar.xz
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.tar.zst
nixlib-7d96d1502015877d12a816658f0bf3bfc7540129.zip
Merge pull request #46534 from obsidiansystems/darwin-to-linux-cross
misc pkgs: Darwin -> Linux cross compilation
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel-headers/default.nix58
-rw-r--r--pkgs/os-specific/linux/kernel-headers/no-dynamic-cc-version-check.patch32
-rw-r--r--pkgs/os-specific/linux/kernel-headers/no-relocs.patch13
3 files changed, 97 insertions, 6 deletions
diff --git a/pkgs/os-specific/linux/kernel-headers/default.nix b/pkgs/os-specific/linux/kernel-headers/default.nix
index 23dcbb05f30a..011668f0c679 100644
--- a/pkgs/os-specific/linux/kernel-headers/default.nix
+++ b/pkgs/os-specific/linux/kernel-headers/default.nix
@@ -1,9 +1,10 @@
 { stdenvNoCC, lib, buildPackages
-, fetchurl, perl
+, fetchurl, fetchpatch, perl
+, elf-header
 }:
 
 let
-  common = { version, sha256, patches ? [] }: stdenvNoCC.mkDerivation {
+  common = { version, sha256, patches ? [] }: stdenvNoCC.mkDerivation ({
     name = "linux-headers-${version}";
 
     src = fetchurl {
@@ -16,18 +17,55 @@ let
     # It may look odd that we use `stdenvNoCC`, and yet explicit depend on a cc.
     # We do this so we have a build->build, not build->host, C compiler.
     depsBuildBuild = [ buildPackages.stdenv.cc ];
-    nativeBuildInputs = [ perl ];
+    # TODO make unconditional next mass rebuild
+    nativeBuildInputs = [ perl ] ++ lib.optional
+      (stdenvNoCC.hostPlatform != stdenvNoCC.buildPlatform)
+      elf-header;
 
     extraIncludeDirs = lib.optional stdenvNoCC.hostPlatform.isPowerPC ["ppc"];
 
+    # "patches" array defaults to 'null' to avoid changing hash
+    # and causing mass rebuild
     inherit patches;
 
-    buildPhase = ''
+    # TODO avoid native hack next rebuild
+    makeFlags = if stdenvNoCC.hostPlatform == stdenvNoCC.buildPlatform then null else [
+      "SHELL=bash"
+      # Avoid use of runtime build->host compilers for checks. These
+      # checks only cared to work around bugs in very old compilers, so
+      # these changes should be safe.
+      "cc-version:=9999"
+      "cc-fullversion:=999999"
+      # `$(..)` expanded by make alone
+      "HOSTCC:=$(BUILD_CC)"
+      "HOSTCXX:=$(BUILD_CXX)"
+    ];
+
+    # TODO avoid native hack next rebuild
+    # Skip clean on darwin, case-sensitivity issues.
+    buildPhase = if stdenvNoCC.hostPlatform == stdenvNoCC.buildPlatform then ''
       make mrproper headers_check SHELL=bash
+    '' else lib.optionalString (!stdenvNoCC.buildPlatform.isDarwin) ''
+      make mrproper $makeFlags
+    ''
+    # For some reason, doing `make install_headers` twice, first without
+    # INSTALL_HDR_PATH=$out then with, is neccessary to get this to work
+    # for darwin cross. @Ericson2314 has no idea why.
+    + ''
+      make headers_install $makeFlags
+    '';
+
+    # TODO avoid native hack next rebuild
+    checkPhase = if stdenvNoCC.hostPlatform == stdenvNoCC.buildPlatform then null else ''
+      make headers_check $makeFlags
     '';
 
-    installPhase = ''
+    # TODO avoid native hack next rebuild
+    installPhase = (if stdenvNoCC.hostPlatform == stdenvNoCC.buildPlatform then ''
       make INSTALL_HDR_PATH=$out headers_install
+    '' else ''
+      make headers_install INSTALL_HDR_PATH=$out $makeFlags
+    '') + ''
 
       # Some builds (e.g. KVM) want a kernel.release.
       mkdir -p $out/include/config
@@ -39,11 +77,19 @@ let
       license = licenses.gpl2;
       platforms = platforms.linux;
     };
-  };
+  } // lib.optionalAttrs (stdenvNoCC.hostPlatform != stdenvNoCC.buildPlatform) {
+    # TODO Make unconditional next mass rebuild
+    hardeningDisable = lib.optional stdenvNoCC.buildPlatform.isDarwin "format";
+  });
 in {
 
   linuxHeaders = common {
     version = "4.18.3";
     sha256 = "1m23hjd02bg8mqnd8dc4z4m3kxds1cyrc6j5saiwnhzbz373rvc1";
+    # TODO make unconditional next mass rebuild
+    patches = lib.optionals (stdenvNoCC.hostPlatform != stdenvNoCC.buildPlatform) [
+       ./no-relocs.patch # for building x86 kernel headers on non-ELF platforms
+       ./no-dynamic-cc-version-check.patch # so we can use `stdenvNoCC`, see `makeFlags` above
+    ];
   };
 }
diff --git a/pkgs/os-specific/linux/kernel-headers/no-dynamic-cc-version-check.patch b/pkgs/os-specific/linux/kernel-headers/no-dynamic-cc-version-check.patch
new file mode 100644
index 000000000000..9b582cac7153
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel-headers/no-dynamic-cc-version-check.patch
@@ -0,0 +1,32 @@
+diff --git a/Makefile b/Makefile
+index 863f58503bee..b778d5023208 100644
+--- a/Makefile
++++ b/Makefile
+@@ -501,11 +501,9 @@ KBUILD_CFLAGS      += $(call cc-option,-fno-PIE)
+ KBUILD_AFLAGS  += $(call cc-option,-fno-PIE)
+ 
+ # check for 'asm goto'
+-ifeq ($(shell $(CONFIG_SHELL) $(srctree)/scripts/gcc-goto.sh $(CC) $(KBUILD_CFLAGS)), y)
+   CC_HAVE_ASM_GOTO := 1
+   KBUILD_CFLAGS += -DCC_HAVE_ASM_GOTO
+   KBUILD_AFLAGS += -DCC_HAVE_ASM_GOTO
+-endif
+ 
+ # The expansion should be delayed until arch/$(SRCARCH)/Makefile is included.
+ # Some architectures define CROSS_COMPILE in arch/$(SRCARCH)/Makefile.
+diff --git a/scripts/Kbuild.include b/scripts/Kbuild.include
+index 065324a8046f..d09c67194549 100644
+--- a/scripts/Kbuild.include
++++ b/scripts/Kbuild.include
+@@ -216,11 +216,8 @@ cc-disable-warning = $(call try-run-cached,\
+ cc-name = $(call shell-cached,$(CC) -v 2>&1 | grep -q "clang version" && echo clang || echo gcc)
+ 
+ # cc-version
+-cc-version = $(shell $(CONFIG_SHELL) $(srctree)/scripts/gcc-version.sh $(CC))
+ 
+ # cc-fullversion
+-cc-fullversion = $(shell $(CONFIG_SHELL) \
+-	$(srctree)/scripts/gcc-version.sh -p $(CC))
+ 
+ # cc-ifversion
+ # Usage:  EXTRA_CFLAGS += $(call cc-ifversion, -lt, 0402, -O1)
diff --git a/pkgs/os-specific/linux/kernel-headers/no-relocs.patch b/pkgs/os-specific/linux/kernel-headers/no-relocs.patch
new file mode 100644
index 000000000000..67e8b19e23bd
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel-headers/no-relocs.patch
@@ -0,0 +1,13 @@
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index fad55160dcb9..a48c8331cbb2 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -239,7 +239,7 @@ ifdef CONFIG_RETPOLINE
+ endif
+ 
+ archscripts: scripts_basic
+-	$(Q)$(MAKE) $(build)=arch/x86/tools relocs
++	$(Q)$(MAKE) $(build)=arch/x86/tools
+ 
+ ###
+ # Syscall table generation